Public Date:
729808: CVE-2011-2905 kernel: perf tools: may parse user-controlled configuration file

The MITRE CVE dictionary describes this issue as:

Untrusted search path vulnerability in the perf_config function in tools/perf/util/config.c in perf, as distributed in the Linux kernel before 3.1, allows local users to overwrite arbitrary files via a crafted config file in the current working directory.

Find out more about CVE-2011-2905 from the MITRE CVE dictionary dictionary and NIST NVD.


This issue did not affect Red Hat Enterprise Linux 4 and 5 as they did not include support for perf. This did not affect Red Hat Enterprise MRG as it uses the perf package from Red Hat Enterprise Linux 6. This has been addressed in Red Hat Enterprise Linux 6 via

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 2.6
Base Metrics AV:L/AC:H/Au:N/C:N/I:P/A:P
Access Vector Local
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux version 6 (kernel) RHSA-2011:1465 2011-11-22

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 5 kernel Not affected
Red Hat Enterprise Linux 4 kernel Not affected