Red Hat Customer Portal

Skip to main content

CVE-2011-2485

Impact:
Low
Public Date:
2011-06-23
Bugzilla:
715337: CVE-2011-2485 gdk-pixbuf: incorrect error detection in the GIF image loader

The MITRE CVE dictionary describes this issue as:

The gdk_pixbuf__gif_image_load function in gdk-pixbuf/io-gif.c in gdk-pixbuf before 2.23.5 does not properly handle certain return values, which allows remote attackers to cause a denial of service (memory consumption) via a crafted GIF image file.

Find out more about CVE-2011-2485 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 4.3
Base Metrics AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 6 pidgin Affected
Red Hat Enterprise Linux 6 gtk2 Affected
Red Hat Enterprise Linux 5 gdk-pixbuf Under investigation
Red Hat Enterprise Linux 5 gtk2 Affected
Red Hat Enterprise Linux 5 pidgin Affected
Red Hat Enterprise Linux 4 evolution28-gtk2 Affected
Red Hat Enterprise Linux 4 frysk Under investigation
Red Hat Enterprise Linux 4 gtk2 Affected
Red Hat Enterprise Linux 4 gdk-pixbuf Under investigation

Acknowledgements

Red Hat would like to thank the Pidgin project for reporting this issue. Upstream acknowledges Mark Doliner as the original reporter.

Last Modified