Skip to navigation

CVE Database

CVE-2011-1527

Impact: Moderate
Public: 2011-10-18
Bugzilla: 737711: CVE-2011-1527 CVE-2011-1528 CVE-2011-1529 CVE-2011-4151 krb5: KDC denial of service vulnerabilities (MITKRB5-SA-2011-006)

Details

The MITRE CVE dictionary describes this issue as:

The kdb_ldap plugin in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.9 through 1.9.1, when the LDAP back end is used, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a kinit operation with incorrect string case for the realm, related to the is_principal_in_realm, krb5_set_error_message, krb5_ldap_get_principal, and process_as_req functions.

Find out more about CVE-2011-1527 from the MITRE CVE dictionary and NIST NVD.

Statement

Not vulnerable. This issue did not affect the versions of krb5 as shipped with Red Hat Enterprise Linux 4 or 5.

CVSS v2 metrics

Base Score: 5.0
Base Metrics: AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector: Network
Access Complexity: Low
Authentication: None
Confidentiality Impact: None
Integrity Impact: None
Availability Impact: Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat security errata

Platform Errata Release Date
Red Hat Enterprise Linux version 6 (krb5) RHSA-2011:1379 October 18, 2011

External References

http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2011-006.txt

Acknowledgements

Red Hat would like to thank the MIT Kerberos project for reporting this issue. Upstream acknowledges Andrej Ota as the original reporter.

This page is generated automatically and has not been checked for errors or omissions.

For clarification or corrections please contact the Red Hat Security Response Team.