You are here

CVE-2011-1148

Vincent (CVE) Danen's picture
Use-after-free vulnerability in the substr_replace function in PHP 5.3.6 and earlier allows context-dependent attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact by using the same variable for multiple arguments.

Details Source

Mitre

Statement

This issue did not affect the versions of php as shipped with Red Hat Enterprise Linux 4.

Public Date

2011-03-13 00:00:00

Impact

Moderate

Bugzilla

CVE-2011-1148 php: use-after-free vulnerability in substr_replace()

Bugzilla ID

688 958

CVSS Status

verified

Base Score

6.80

Base Metrics

AV:N/AC:M/Au:N/C:P/I:P/A:P

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 6 (php) RHSA-2011:1423 2011-11-02
Red Hat Enterprise Linux 5 (php) RHSA-2012:0033 2012-01-18
Red Hat Enterprise Linux 5 (php53) RHSA-2011:1423 2011-11-02

CWE

CWE-416

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 4 php Not affected