You are here

CVE-2011-0058

Vincent (CVE) Danen's picture
Buffer overflow in Mozilla Firefox before 3.5.17 and 3.6.x before 3.6.14, and SeaMonkey before 2.0.12, on Windows allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a long string that triggers construction of a long text run.

Details Source

Mitre

Public Date

2011-03-01 00:00:00

Impact

Critical

Bugzilla

CVE-2011-0058 Mozilla memory corruption during text run construction (MFSA 2011-07)

Bugzilla ID

675 143

CVSS Status

verified

Base Score

6.80

Base Metrics

AV:N/AC:M/Au:N/C:P/I:P/A:P

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 6 (firefox) RHSA-2011:0310 2011-03-02
Red Hat Enterprise Linux 5 (firefox) RHSA-2011:0310 2011-03-02
Red Hat Enterprise Linux 4 (firefox) RHSA-2011:0310 2011-03-02

Affected Packages State

Platform Package State
Red Hat Enterprise Linux version 6 xulrunner 1.9.2.14-3.el6_0 Fixed
Red Hat Enterprise Linux version 5 xulrunner 1.9.2.14-4.el5_6 Fixed
Red Hat Enterprise Linux Server EUS (v. 6.0) firefox Affected
Red Hat Enterprise Linux EUS (v. 5.6 server) firefox Affected