Red Hat Customer Portal

Skip to main content

CVE-2010-1169

PostgreSQL 7.4 before 7.4.29, 8.0 before 8.0.25, 8.1 before 8.1.21, 8.2 before 8.2.17, 8.3 before 8.3.11, 8.4 before 8.4.4, and 9.0 Beta before 9.0 Beta 2 does not properly restrict PL/perl procedures, which allows remote authenticated users, with database-creation privileges, to execute arbitrary Perl code via a crafted script, related to the Safe module (aka Safe.pm) for Perl. NOTE: some sources report that this issue is the same as CVE-2010-1447.

Details Source

Mitre

Public Date

2010-05-17 00:00:00

Impact

Moderate

Bugzilla

CVE-2010-1169 PostgreSQL: PL/Perl Intended restriction bypass

Bugzilla ID

582 615

CVSS Status

verified

Base Score

5.20

Base Metrics

AV:A/AC:L/Au:S/C:P/I:P/A:P

Acknowledgements

Red Hat would like to thank Tim Bunce for responsibly reporting this issue.

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 5 (postgresql) RHSA-2010:0429 2010-05-19
Red Hat Enterprise Linux 4 (postgresql) RHSA-2010:0428 2010-05-19
Red Hat Enterprise Linux 3 (rh-postgresql) RHSA-2010:0427 2010-05-19
Red Hat Enterprise Linux 5 (postgresql84) RHSA-2010:0430 2010-05-19

Affected Packages State

Platform Package State
Red Hat Enterprise Linux Server EUS (v. 6.0) postgresql Affected