CVE Database

CVE-2010-0624

Impact: Moderate
Public: 2010-03-10
Bugzilla: 564368: CVE-2010-0624 tar, cpio: Heap-based buffer overflow by expanding a specially-crafted archive
IAVA: 2015-A-0150

Details

The MITRE CVE dictionary describes this issue as:

Heap-based buffer overflow in the rmt_read__ function in lib/rtapelib.c in the rmt client functionality in GNU tar before 1.23 and GNU cpio before 2.11 allows remote rmt servers to cause a denial of service (memory corruption) or possibly execute arbitrary code by sending more data than was requested, related to archive filenames that contain a : (colon) character.

Find out more about CVE-2010-0624 from the MITRE CVE dictionary and NIST NVD.

CVSS v2 metrics

Base Score: 5.1
Base Metrics: AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector: Network
Access Complexity: High
Authentication: None
Confidentiality Impact: Partial
Integrity Impact: Partial
Availability Impact: Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat security errata

Platform Errata Release Date
Red Hat Enterprise Linux version 3 (cpio) RHSA-2010:0145 March 16, 2010
Red Hat Enterprise Linux version 3 (tar) RHSA-2010:0142 March 16, 2010
Red Hat Enterprise Linux version 4 (cpio) RHSA-2010:0143 March 16, 2010
Red Hat Enterprise Linux version 4 (tar) RHSA-2010:0141 March 15, 2010
Red Hat Enterprise Linux version 5 (cpio) RHSA-2010:0144 March 16, 2010
Red Hat Enterprise Linux version 5 (tar) RHSA-2010:0141 March 15, 2010

External References

Acknowledgements

Red Hat would like to thank Jakob Lell for responsibly reporting this issue.

This page is generated automatically and has not been checked for errors or omissions.

For clarification or corrections please contact the Red Hat Security Response Team.