Red Hat Customer Portal

Skip to main content

CVE-2009-3720

Impact:
Moderate
Public Date:
2009-01-17
IAVA:
2012-A-0020
Bugzilla:
531697: CVE-2009-3720 expat: buffer over-read and crash on XML with malformed UTF-8 sequences

The MITRE CVE dictionary describes this issue as:

The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.

Find out more about CVE-2009-3720 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 5
Base Metrics AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 4 (4Suite) RHSA-2009:1572 2009-11-10
Red Hat Enterprise Linux 5 (PyXML) RHSA-2010:0002 2010-01-04
Red Hat Enterprise Linux 4 (expat) RHSA-2009:1625 2009-12-07
Red Hat Enterprise Linux 4 (PyXML) RHSA-2010:0002 2010-01-04
Red Hat Enterprise Linux 4 (python) RHSA-2011:0491 2011-05-05
Red Hat Enterprise Linux 3 (4Suite) RHSA-2009:1572 2009-11-10
Red Hat Enterprise Linux 3 (expat) RHSA-2009:1625 2009-12-07
Red Hat JBoss Web Server 1.0 RHSA-2011:0896 2011-06-22
Red Hat Enterprise Linux 5 (expat) RHSA-2009:1625 2009-12-07
Red Hat Enterprise Linux 5 (python) RHSA-2011:0492 2011-05-05

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 6 python Not affected
Red Hat Enterprise Linux 6 PyXML Not affected
Red Hat Enterprise Linux 6 expat Not affected
Red Hat Enterprise Linux 5 xmlrpc-c Not affected
Red Hat Enterprise Linux 7 expat Not affected
Red Hat Enterprise Linux 6 compat-expat1 Not affected