CVE Database

CVE-2009-3606

Impact: Moderate
Public: 2009-10-14
Bugzilla: 526877: CVE-2009-3606 xpdf/poppler: PSOutputDev::doImageL1Sep integer overflow

Details

The MITRE CVE dictionary describes this issue as:

Integer overflow in the PSOutputDev::doImageL1Sep function in Xpdf before 3.02pl4, and Poppler 0.x, as used in kdegraphics KPDF, might allow remote attackers to execute arbitrary code via a crafted PDF document that triggers a heap-based buffer overflow.

Find out more about CVE-2009-3606 from the MITRE CVE dictionary and NIST NVD.

CVSS v2 metrics

Base Score: 3.7
Base Metrics: AV:L/AC:H/Au:N/C:P/I:P/A:P
Access Vector: Local
Access Complexity: High
Authentication: None
Confidentiality Impact: Partial
Integrity Impact: Partial
Availability Impact: Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat security errata

Platform Errata Release Date
Red Hat Enterprise Linux Desktop Workstation version 5 (kdegraphics) RHSA-2009:1502 October 15, 2009
Red Hat Enterprise Linux Optional Productivity Applications version 5 (kdegraphics) RHSA-2009:1502 October 15, 2009
Red Hat Enterprise Linux version 3 (xpdf) RHSA-2009:1500 October 15, 2009
Red Hat Enterprise Linux version 4 (gpdf) RHSA-2009:0458 April 30, 2009
Red Hat Enterprise Linux version 4 (xpdf) RHSA-2009:1501 October 15, 2009
Red Hat Enterprise Linux version 5 (poppler) RHSA-2009:0480 May 13, 2009

External References

This page is generated automatically and has not been checked for errors or omissions.

For clarification or corrections please contact the Red Hat Security Response Team.