Skip to navigation

CVE Database

CVE-2008-5557

Impact: Moderate
Public: 2008-08-05
Bugzilla: 478848: CVE-2008-5557 php: Heap-based buffer overflow in the mbstring extension via crafted string containing a HTML entity (arb code execution)

Details

The MITRE CVE dictionary describes this issue as:

Heap-based buffer overflow in ext/mbstring/libmbfl/filters/mbfilter_htmlent.c in the mbstring extension in PHP 4.3.0 through 5.2.6 allows context-dependent attackers to execute arbitrary code via a crafted string containing an HTML entity, which is not properly handled during Unicode conversion, related to the (1) mb_convert_encoding, (2) mb_check_encoding, (3) mb_convert_variables, and (4) mb_parse_str functions.

Find out more about CVE-2008-5557 from the MITRE CVE dictionary and NIST NVD.

Red Hat security errata

Platform Errata Release Date
Red Hat Application Stack v2 for Enterprise Linux (v.5) (php) RHSA-2009:0350 April 14, 2009
Red Hat Enterprise Linux version 3 (php) RHSA-2009:0337 April 06, 2009
Red Hat Enterprise Linux version 4 (php) RHSA-2009:0337 April 06, 2009
Red Hat Enterprise Linux version 5 (php) RHSA-2009:0338 April 06, 2009

External References

This page is generated automatically and has not been checked for errors or omissions.

For clarification or corrections please contact the Red Hat Security Response Team.