CVE-2008-2802

Impact:
Critical
Public Date:
2008-07-02
Bugzilla:
452600: CVE-2008-2802 Firefox arbitrary JavaScript code execution

The MITRE CVE dictionary describes this issue as:

Mozilla Firefox before 2.0.0.15, Thunderbird 2.0.0.14 and earlier, and SeaMonkey before 1.1.10 allow remote attackers to execute arbitrary code via an XUL document that includes a script from a chrome: URI that points to a fastload file, related to this file's "privilege level."

Find out more about CVE-2008-2802 from the MITRE CVE dictionary dictionary and NIST NVD.

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux version 3 (seamonkey) RHSA-2008:0547 2008-07-02
Red Hat Enterprise Linux version 5 (firefox) RHSA-2008:0569 2008-07-02
Red Hat Enterprise Linux Desktop version 5 (thunderbird) RHSA-2008:0616 2008-07-23
Red Hat Enterprise Linux version 4 (seamonkey) RHSA-2008:0547 2008-07-02
Red Hat Enterprise Linux version 4 (thunderbird) RHSA-2008:0616 2008-07-23
Red Hat Enterprise Linux Optional Productivity Applications version 5 (thunderbird) RHSA-2008:0616 2008-07-23
Red Hat Enterprise Linux version 4 (firefox) RHSA-2008:0549 2008-07-02
Red Hat Enterprise Linux version 2.1 (seamonkey) RHSA-2008:0547 2008-07-02

Affected Packages State

Platform Package State
Red Hat Enterprise Linux version 5 yelp 2.16.0-19.el5 Fixed
Red Hat Enterprise Linux version 5 devhelp 0.12-17.el5 Fixed
Red Hat Enterprise Linux version 5 xulrunner 1.9-1.el5 Fixed