JBoss EAP 6.2 Performance Testing

Latest response

When we tried to run 30 requests per second from a Netty server to Stateless Session EJB in JBossEAP 6.2 we get the following exception randomly.
And from internet we came to know that it is known bug. Is it resolved in JBossEAP6.2 or is there any work around for this?

18:04:57,388 ERROR [org.jboss.as.ejb3] (EJB default - 119) JBAS014250: Could not write method invocation failure for method public abstract java.util.Map com.cds.processing.ptch.ejb.PTCHRemote.authorize(java.util.Map) on bean named for appname modulename distinctname due to: java.io.IOException: JBAS014560: Could not open message outputstream for writing to Channel
at org.jboss.as.ejb3.remote.protocol.versionone.MethodInvocationMessageHandler.writeMethodInvocationResponse(MethodInvocationMessageHandler.java:362)
at org.jboss.as.ejb3.remote.protocol.versionone.MethodInvocationMessageHandler.access$600(MethodInvocationMessageHandler.java:70)
at org.jboss.as.ejb3.remote.protocol.versionone.MethodInvocationMessageHandler$1.run(MethodInvocationMessageHandler.java:246)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [rt.jar:1.7.0_45]
at java.util.concurrent.FutureTask.run(Unknown Source) [rt.jar:1.7.0_45]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [rt.jar:1.7.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [rt.jar:1.7.0_45]
at java.lang.Thread.run(Unknown Source) [rt.jar:1.7.0_45]
at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.1.1.Final-redhat-1.jar:2.1.1.Final-redhat-1]
Caused by: org.jboss.remoting3.NotOpenException: Writes closed
at org.jboss.remoting3.remote.RemoteConnectionChannel.openOutboundMessage(RemoteConnectionChannel.java:108) [jboss-remoting-3.2.18.GA-redhat-1.jar:3.2.18.GA-redhat-1]
at org.jboss.remoting3.remote.RemoteConnectionChannel.writeMessage(RemoteConnectionChannel.java:297) [jboss-remoting-3.2.18.GA-redhat-1.jar:3.2.18.GA-redhat-1]
at org.jboss.as.ejb3.remote.protocol.versionone.ChannelAssociation.acquireChannelMessageOutputStream(ChannelAssociation.java:68)
at org.jboss.as.ejb3.remote.protocol.versionone.MethodInvocationMessageHandler.writeMethodInvocationResponse(MethodInvocationMessageHandler.java:360)

Thanks,
Shanthi

Shanthi Nataraj Thangavel's picture

Responses

Could you show the client code how you access the SLSB?

Hello Fink,
Here is the client code to access the EJB:

try{
final String appName = "";
final String moduleName = "MYEJB";
final String distinctName = "";
final String beanName ="MYBean";
final String viewClassName =MYRemote.class.getName();
Properties jndiProps = new Properties();
jndiProps.put(Context.INITIAL_CONTEXT_FACTORY,
"org.jboss.naming.remote.client.InitialContextFactory");
jndiProps.put(Context.PROVIDER_URL, "remote://127.0.0.1:4447");
jndiProps.put(Context.SECURITY_PRINCIPAL, );
jndiProps.put(Context.SECURITY_CREDENTIALS,
);
jndiProps.put("jboss.naming.client.ejb.context", true);

        // create a context passing these properties
        Context ctx = new InitialContext(jndiProps);
        // lookup the bean Remote
        MYRemote myBean = (MYRemote) ctx
                .lookup(appName + "/" + moduleName + "/" + distinctName + "/" + beanName + "!" + viewClassName);



    } catch(Exception e) {
        e.printStackTrace();
        throw new RuntimeException();
    }

Method Call:
myBean.myMethod(requestMap);

Thank you for help
Shanthi

This has nothing to do with netty.
You use remote-naming which might have issues.
It is receommended to use the jboss-ejb-client.properties and the related approach for the invocation.

Did you get the solution to this issue.
I am seeing the same ERROR in my application

Hi Wolf-Dieter, I am using the technique you suggested. Still seeing the same error when performance testing.

Regards, Jeremy

Hi Jeremy,

sorry, did not saw that earlier. If this is still an issue I would recommend to open a case for this. Also the KCS articles show different approaches and what the drawbacks are.

Hi Guys,

I had same issue, Did you guys have solution for this issue ?

Thanks, Chary

Hi, My advice is to version bump to EAP 6.4 and re-test. There have been a number of issues resolved in the remoting layer since 6.2. Release Notes:

6.3 https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html/6.3.0_Release_Notes/Changes_in_This_Release.html#idp12410832

6.4 https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.4/html/6.4.0_Release_Notes/sect-Resolved_and_Known_Issues.html#Resolved_Issues

Regards, Jeremy

Hi, I am getting similar issue for Jboss 6.4.5 version. Did anyone find the solution for this issue ?

Thanks , Manish

Was this helpful?

We appreciate your feedback. Leave a comment if you would like to provide more detail.
It looks like we have some work to do. Leave a comment to let us know how we could improve.
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.