error on jboss runtime in eclipse after patching jboss eap 6.2.2

Latest response

We patched to eap 6.2.2 because of this bug https://bugzilla.redhat.com/show_bug.cgi?id=988280 . It seemes to be ok with getops but now we have troubles to build with eclipse (kepler with jboss tools 2.4.1).

We got invalid jar files for the server modules.

Example :

Archive for required library: '/home/jboss/jboss-eap-6.2/modules/system/layers/base/javax/el/api/main/jboss-el-api_2.2_spec-1.0.2.Final-redhat-1.jar' in project 'VigilanceServeur' cannot be read or is not a valid ZIP

Responses

Please see this discussion:
https://access.redhat.com/site/discussions/726623

As Takayuki says, patched JAR's are "corrupt" so avoid misusing them. It sounds like Eclipse just isn't picking up the patched JARs so either a refresh or adding the patched JAR's to the build path should fix this.

By the way, that bug was fixed in EAP 6.2.0 and not 6.2.2 from what I can tell.

Thanks for your answers I will try to update the build path