Unable to register Linux Server

Latest response

Hi,

I am trying to register Rhel 6.5 x86_64 (evaluation) which is installed on a vm within vSphere with a static ip. I can ping any host within and outside the network successfully. But when I am trying to register in command line (as explained here https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/5/html/Deployment_Guide/registering-cmd.html) I am getting the error message:

$subscription-manager register
$Username: username
$Password: password
Network error, unable to connect to server.

But when I ping 209.132.183.181 (redhat.com) the ping is working just fine.

I installed the same RHEL Server on my local machine where DHCP is configured and I can register.

Responses

It sounds like it could either be your DNS settings, or your network segment does not allow outbound HTTP/HTTPS (or you need a proxy).

Please run the following and let us know what it returns.

cat /etc/resolv.conf
dig www.redhat.com
cd /tmp && wget http://www.redhat.com/index.html

After re-reading your post, I really believe it's your DNS. Make sure you have the correct DNS settings in your /etc/resolv.conf - if you don't know what your internal DNS servers are, you can use

nameserver 8.8.8.8
nameserver 8.8.4.4

Thank You very much James. It saved my "head-scratching" hours.

Many Many Thanks. Was stuck at this point. Now it works perfectly.

Thank you for the wonderful information and was able to register :)

Hello james,

While running above cmd's got below results. Please help me on this. My subscription-manager register got failed with below error. Registering to: subscription.rhsm.redhat.com:443/subscription Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information. [root@pc104 ~]# cat /etc/resolv.conf

Generated by NetworkManager

search linux.com nameserver 8.8.8.8 nameserver 8.8.4.4 [root@pc104 ~]# dig www.redhat.com

; <<>> DiG 9.9.4-RedHat-9.9.4-36.el7 <<>> www.redhat.com ;; global options: +cmd ;; connection timed out; no servers could be reached [root@pc104 ~]# cd /tmp && wget http://www.redhat.com/index.html --2021-06-04 11:58:37-- http://www.redhat.com/index.html Resolving www.redhat.com (www.redhat.com)... failed: Name or service not known. wget: unable to resolve host address ‘www.redhat.com’ [root@pc104 tmp]#

I changed the /etc/resolv.conf to the correct DNS settings and I could register. Thank you for the quick reply. Problem is solved :)

Even I was facing the same issue. This quickly resolved the issue. Thanks for posting the solution.

Thank you James, fixed my issue as well.

It could be a Bad internet connection

I am not able to register Red Hat Enterprise Linux Server release 6.4 , Error is "cannot parse argument: register" please help urgent

Hi ,

i am not able to register Red Hat Enterprise Linux Server release 7.3 . i am getting below mentioned errors. "Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information."

Venkatesh Shanmugavel, did you try out the steps mentioned in this discussion by "James Radtke " that should help, otherwise, it might be a proxy server not set properly. please check for it.

I can ping the hostname but still getting the error above.

Hi Eyuep,

Can you telnet www.redhat.com 443 from your server?

Regards,

Jan Gerrit

thank you worked after setting DNS

Hi James,

Great article. One point of concern, the external nameservers: nameserver 8.8.8.8 nameserver 8.8.4.4 Not all ISPs or Datacenter Network Administrators allow direct queries outside their network infrastructure.

Regards,

Jan Gerrit

Hi am trying to attach my subscription. But its giving out error. When i telnet www.redhat.com 443 i am getting an error telnet: connect to address 2600:140f:6:184:d44 network is unreachable.

Hi John,

This looks like your DNS is configured to return IPv6 addresses, where your server is not configured to handle IPv6 addresses.

Regards,

Jan Gerrit

Hi Jan,

Thanks for the update. What should I do now? Kindly help.

JB

Hi Jan... Now am getting an error : host name lookup failure and my hosts file is

127.0.0.1 DMZWEB2 localhost.localdomain localhost4 localhost4.localdomain4 ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 10.39.24.106 DMZWEB1 10.39.24.107 DMZWEB2 210.210.24.66 www.billdesk.com billdesk 117.239.8.204 webmail.cmrl.in SMTP server1 117.239.8.205 webmail.cmrl.in SMTP server2

Kindly help

Trying to run subscription-manager register ans entering user und password I got the error message: Error: incorrect Login Informations When I Try the same User und password on redhat.com it is working

What´s wrong?

Hi , I am trying to register using subscription-manager but it failing saying "Network Error: Unable to connect to server"

I tried "ping subscription.rhsm.redhat.com", DNS resolves to 209.132.183.108 but its not reachable.

"telnet www.redhat.com 443" is failing also on "trying ..." message.

please help.

PS: I am behind proxy and have added proxy details in /etc/environment, /etc/rhsm/rhsm.conf files. I am using Red Hat Virtualization Hypervisor 4.2 .

RHEL 7.2 is installed on my stem. I am unable to register the system using subscription manager. I tried "ping subscription.rhsm.redhat.com", DNS resolves to 209.132.183.108 but its not reachable. Can anyone help me in this regard.

I am unable to ping the server too. ping 209.132.183.181 . Kindly post some light into this problem.

My kernal version is [root@localhost ~]# cat /proc/version Linux version 3.10.0-327.10.1.el7.x86_64 (mockbuild@x86-021.build.eng.bos.redhat .com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Sat Jan 23 04 :54:55 EST 2016

I had the same error after playing with ansible-module redhat_subscription and try to register on my katello-system. I had to copy a /etc/rhsm/rhsm.conf from a healthy / already registerd maschine.

same error here, i want the client server connect to satellite server with content view and i run command #subscription-manager register --org="xxx" --activationkey="xxx"

and the message : "Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information." what the resolution?

Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information.

how to resolved we nameserver has fixed, and google dns ip has pinging but still error is came

Hi All I have tried all of the above and still cannot register one of my servers. I have copied /etc/rhsm/rhsm.conf from a working server and also ping subscription.rhsm.redhat.com all of which works fine. Until I try and register then get Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information.

Excelente solucion, muchas gracias

The above didn't work for me (due to internal firewall restrictions). The solution is to edit /etc/rhsm/rhsm.conf adding the right proxy info.

sorry, can you provide what proxy setting you'v added? what if we dont have any proxy server but still having issues with registering and like you, all the methods mentioned above is not working for us, so I am thinkng maybe your solution could help my issue

Apologies for the late reply. In my case, I added my company's proxy ip in the "proxy_hostname" field and the port in "proxy_port". I hope this helps.

I am having issues registering system with redhat... I can telnet to www.redhat.com 443 but couldnt register using the gui so tried instead from command line below . Although I am prompted to enter username and password (which i use to login to redhat customer portal).. it then throws up the error below

subscription-manager register

Registering to: subscription.rhsm.redhat.com:443/subscription Username: username Password: password Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log fo r more information.

These are the results of running the x3 commands you suggested

cat /etc/resolv.conf nameserver 10.xxx.xx.xx nameserver 10.xxx.xx.xx

dig www.redhat.com [root@tsuk1dpr02 ~]# dig www.redhat.com

; <<>> DiG 9.9.4-RedHat-9.9.4-72.el7 <<>> www.redhat.com ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43874 ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION: ; EDNS: version: 0, flags:; udp: 4000 ;; QUESTION SECTION: ;www.redhat.com. IN A

;; ANSWER SECTION: www.redhat.com. 2958 IN CNAME ds-www.redhat.com.edgekey.net. ds-www.redhat.com.edgekey.net. 5860 IN CNAME ds-www.redhat.com.edgekey.net.globalredir.akadns.net. ds-www.redhat.com.edgekey.net.globalredir.akadns.net. 2129 IN CNAME e3396.dscx.akamaiedge.net. e3396.dscx.akamaiedge.net. 20 IN A 104.86.130.61

;; Query time: 25 msec ;; SERVER: 10.190.16.10#53(10.190.16.10) ;; WHEN: Wed Jun 09 16:06:05 IST 2021 ;; MSG SIZE rcvd: 201

cd /tmp && wget http://www.redhat.com/index.html [root@tsuk1dpr02 ~]# cd /tmp && wget http://www.redhat.com/index.html --2021-06-09 16:08:13-- http://www.redhat.com/index.html Resolving www.redhat.com (www.redhat.com)... 104.86.130.61, 2a02:26f0:e8:4aa::d44, 2a02:26f0:e8:4ab::d44 Connecting to www.redhat.com (www.redhat.com)|104.86.130.61|:80... connected. HTTP request sent, awaiting response... 403 Forbidden 2021-06-09 16:08:13 ERROR 403: Forbidden.

Not sure what the error above points to as have no issue below connecting through port 443 ?

telnet subscription.rhsm.redhat.com 443

Trying 209.132.183.108... Connected to subscription.rhsm.redhat.com. Escape character is '^]'.

telnet www.redhat.com 443 telnet www.redhat.com 443

Trying 104.86.130.61... Connected to www.redhat.com. Escape character is '^]'.

I also looked at the workaround suggested in the following article https://access.redhat.com/solutions/1323123

but the resolution suggested below doesnt seem to apply to our issue ..

Check that the host name given in the /etc/rhsm/rhsm.conf file is correct and can be resolved. ... hostname = subscription.rhsm.redhat.com

nslookup subscription.rhsm.redhat.com

Server: xx.xxx.xx.xx Address: xx.xxx.xx.xx#53

Non-authoritative answer: Name: subscription.rhsm.redhat.com Address: 209.132.183.108

Verify and correct DNS server information in /etc/resolv.conf file. If host file is used for name resolution instead of DNS, make sure /etc/hosts, has an entry for satellite server. Verify baseurl is set to baseurl= https://cdn.redhat.com in /etc/rhsm/rhsm.conf file. > It is set to this

Also prior to attempting to register server i cleaned up subscription manager as per below

subscription-manager remove --all subscription-manager unregister subscription-manager clean yum clean all rm -rf /var/cache/yum/*

For me it was a matter of just performing the:

subscription-manager clean

Performing this allowed me to finally perform an update.