Satellite 5.6 - virtual nodes shown as physical

Latest response

Hi all,

I have just finished Satellite upgrade to 5.6. It seems it works well but when I go to:

Systems (top tab) -> Systems (left) -> Physical Systems

I can see that there are two hosts (RH 5.1) which are running under Vmware.
Is it bug in Satellite or is it related to RH release on these two nodes ?

Regards
Przemek

Responses

Hello Przemek,

There no such known bug in Red Hat Satellite v 5.6 but it might be possible that 2 RHEL 5.1 client systems are not flex eligible so they are consuming Physical entitlements.

To know more about Flex Guest entitlements you can check - https://access.redhat.com/site/solutions/17397

To fix this issue you may need to update rhn-client-tools , rhn-setup packages on client to version <= 0.4.20-33.el5 provided by errata - http://rhn.redhat.com/errata/RHBA-2010-0270.html. Can you please let us know version of rhn-client-tools package installed on 2 Vmware guest systems ?

To convert systems (which are flex eligible) consuming physical / regular entitlement to Flex you can try accessing bellow link

https://satellite.example.com/rhn/systems/entitlements/EligibleFlexGuests.do

Note: Replace satellite.example.com with hostname/IP of your satellite server.

Regards,
Ashish

Hello Ashish,

on both nodes we have rhn-client-tools-0.4.20-86.el5 installed.

When I go to:
https://our-satellite/rhn/systems/entitlements/EligibleFlexGuests.do
I get:
There are no eligible flex guest systems consuming regular entitlements.

Regards
Przemek

Hi Przemek,

okie, we need to check sosreport of client system. So can you please open ticket with Red Hat Support , we will assist you to get this issue solved.

Have you already tried re-registering those virtual system to satellite ? if yes, still they are consuming physical entitlement ?

Regards,
Ashish

Hi Ashish,

Since re-registering didn't help I will definitely open a ticket.

Hmm,

I have tried again re-registering and it worked. It seems I must have done something wrong ...

Hi Przemyslaw - could you open a ticket for that? That seems like a bug (possibly). As though some identification did not follow from 5.5 to 5.6 with the upgrade. I don't track my virtual vs physical very closely and I also have not upgraded yet - so, I guess I'll find out when I do ;-)