Unable to verify server's identity: certificate verify failed

Latest response

After doing some hardware changes, now cannot connect to subscription manager. When I try to re-register, I have this error-Unable to verify server's identity: certificate verify failed. Please help. Thank you.

Responses

I discovered in another post that the system time may have caused the issue after bios reset.

# yum update
Loaded plugins: product-id, security, subscription-manager
certificate verify failed
Skipping security plugin, no data
Setting up Update Process
No Packages marked for Update
 

I unsubscibed the system from Subscription Management, and it seems that I cannot re-subscribe it due to the certificate verify failed.

Looks like I may just need some help installing a new certificate.

Resolved. It was the time setting that created the entire issue.

what was the wrong time settings? Got the same error - but cant fix it

same Problem here - i cant fix this error

maybe a firewall in in the middle, simulating "man in the middle"attack, try to "not filter" any package betwen the server and "subscription.rhn.redhat.com" (use a NAT) on http and https.... that may work.

i had this error once, i unistalled all katello packages and reinstalled. it solved the issuel.

Same as Richard: I uninstalled all katello packages and reinstalled. It solved the issue.

Also same as Richard and Meir:

yum remove katello*

then reinstall and re-register.

yum -y localinstall katello* resolved the issue for me.

i have reinstalled the katello package , but still facing the below issue Unable to verify server's identity: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:618)