Enable VLAN tagging on RHEV 3.2

Latest response

What is a best way to enable VLAN tagging on RHEV 3.2 ?

- 2 x RHEV-H hosts (4 nic in bond mode 4)
- Only netwrok is default rhevm network
- Default DC and Default Cluster all on version 3.2
 

Can I click on Networks tab then on "rhevm" and then on "edit" and just click on "Enable VLAN tagging" ?

Of cource then I will need to set VLAN tagging on my switch as well.

Or I need to make new DC, cluster, netwroks and then migrte VMs to it ?

 

Thanks.

Responses

In 3.2, there is no need to create a new DC, Cluster and etc.

- Configure your switch for vlan tagging.

- Edit rhevm logical networm under DC and "enable vlan tagging" and enter correct tag.

- On each hypervisor, go to Network Interfaces -> Set up Host Networks -> Click on the "Pencil" icon near to "rhevm" network to open the "Edit management network" window. Select "Sync Network". Make other changes if needed. Click OK.
This will reconfigure rhevm using vlan tag on the host side. This need to be repeated on all hosts.

Thanks for answer, however I have one more question:

If I first set up switch with vlan tagging I will lose connectivity RHEV-M <--> RHEV-H right? And then I will not be able to change any setting.

Is it ok to first do RHEV-M chnages and then as a last step enable vlan tagging on switch ?

Is it ok to first do RHEV-M chnages and then as a last step enable vlan tagging on switch ?

This is the best approach. Make sure that you uncheck "Verify connectivity between Host and Engine" in "Set up Host Networks" window before clicking ok. Yes, this will also break connection between RHEV-M and hypervisors till you enable the tag on the switch.

You need to expect some outage.

Thanks Sadique for help migrating to VLAN tagging was done successfully.

But it was ugly. Very ugly.
Fist I had to disconect rhevm netwrok from all VMs. Then in one moment both RHEV-H hosts have lost all connectivity and disconnected FC storage efectivly killling all running VMs. Then only one RHEV-M have accepted to change it's netwrok to VLAN tagging.
Only solusion was to login in console to other RHEV-H and set up vlan tagging by hand  (vi /etc/sysconfig/network-scripts/ifcfg-bond3.127) and then do persist on this file. Now this host see 2 rhevm netwroks but it's working :)

Maybe this topic would be good candidate for KB as RHEV 3.2 is different from RHEV 3.0/3.1 regarding this problem.

One more question, what is the sintax for multiple vlans in enable VLAN tagging just space between VLANs or comma or something else ?

1. Enable VLAN tagging: 20,21,30,45
2. Enable VLAN tagging: 20 21 30 45

It sounds bad. I think you should contact to your support to figure out what happened and how can you get rid of the double rhevm network.

 

1. Enable VLAN tagging: 20,21,30,45
2. Enable VLAN tagging: 20 21 30 45

In RHEV you have to set up the VLAN tagging in a way where each logical network has only one VLAN tag (anyhow, it is a logical way) and you have to assign these logical networks to the same NIC. This means you have to create separate logical network for each of your VLANs.