Oracle VM VirtualBox Extension installed...still no USB on guest

Latest response

I installed Virtual Box on my RHEL 6 host. I have four VMs inside. Two are XP, one is Server 2003 Domain Controller, and the last is a member Server 2003 where I'd like to put Exhange 2003 on. I tried enabling the USB, got the prompt to install Oracle VM VirtualBox Extension, did that, and still no USB in my 2nd Server 2003. Do I need anything else? Any help would be appreciated. Thx. Dave

Responses

The easiest way to enable usb direction is open the virtual machine under root user,

because if you open virtual machine under non-root user, the status and some socket which may be used to direct usb to vitaual machine under /proc did not have enough permission.

Try open the virtual machine under root user.

Thanks, it fixed my problem. But I might add that it is best to store the ISOs you want to use on your host machine. I was keeping them on my USB portable and I ran into some conflicts in creating the VMs and applying the USB function to each.

Thanks Again,

Dave