[RHEVM-3.0 Bug] Uploading ISO takes down RHEV Manager

Latest response

Hi,

 

Today I started testing RHEV 3.0 Beta 3. everything went very smooth. Installation, configuration, adding storage, adding hosts,...

 

The only thing I find rather weird is the following :

 

I've an ISO file on the RHEV Manager machine that I want to upload using the rhevm-iso-uploader tool. So i run this :

 

- rhevm-iso-uploader --iso-domain=ISO upload /root/rhel-server-6.1-x86_64-dvd.iso

 

After this the whole RHEV-M just hangs. I need to reboot.

 

I would like to register things like this in some kind of Bugzilla so this can be, but I don't know if that's possible..

 

Regards,

Vincent

Responses

Vincent,

Would you please re-run the command with the -v option.

 

Example:

rhevm-iso-uploader --iso-domain=ISO upload /root/rhel-server-6.1-x86_64-dvd.iso -v

 

Cheers,

Keith

Vincent,

Another thing I'd like you to try is the SSH/SFTP upload capabilities of the ISO uploader.  By default, the ISO uploader will use NFS as the transport to copy the file from the RHEVM to the NFS export.  However, we can also use SSH/SFTP to transfer the file from the RHEVM to the server upon which the ISO domain lives.  Here is a sample invocation:

 

rhevm-iso-uploader -i LegacyISO --ssh-user=root upload my.iso

 

To use SSH/SFTP as the transport you must do the following:

1. Ensure that the server upon which the ISO domain lives actually allows SSH/SFTP access (i.e. can you SSH in to this system).
2. Supply the "--ssh-user" option to the ISO uploader

3. Ensure that the user supplied either has a numeric ID/GID of 36 or it has the authority to SU to ID 36 (e.g. root).

 

Finally, when you elect to use SSH as the transport you may be prompted to the password several times.  You can prevent this from happening by using key based authentication between the RHEVM and the server upon which the ISO domain lives.  Here's how...

1. Assume that the "ssh-user" is root and the ISO domain server is example.com.

2. As root on the RHEVM execute: ssh-copy-id example.com

 

Cheers,

Keith

The rhev-iso-uploader tool does not report upload progress at the moment, thus it may look like the command line hangs while in fact it does the upload.
Note that the iso upload operation may take considerable time depending on your network and the location of the source and destination paths.

To verify that RHEV Manager is still operational please try to go to the administration portal and see if it is responsive, it should be.
Actually you should be able to use RHEV Manager for any task except for attaching the uploading ISO to a Virtual Machine.

If this fails you please try with the -v option that Kieth has mentioned, and please indicate at which stage it hangs.

As for your other query, the Bugzilla system is still not publicly open however you can report issues through support.
This is always preferable as then you have someone drive this and track this to completion.