RHEV 3 beta / Anyone able to survive a reboot ?

Latest response

Hi

 

After I was able to install the RHEV-M 3 beta I could connect to the webinterface and add a DC / Cluster etc.

I failed to add the RHEV-H, looks like of know Problems. So I disable selinux and copy all needed files to /var/www/html. But was not able to add a RHEV-H Host, So I did a reboot, but then the IPA Server don't come up again.

 

Anyone has a Docu which service need to start ? Did not find any list to check my installation.

 

thanks Mike

 

*************************************************

[root@rhevm3-beta log]# service ipa start
Starting Directory Service
Starting dirsrv:
    RHEVM3-BETA-GECCO-CH...                                [  OK  ]
Failed to read data from Directory Service: Unknown error when retrieving list of services from LDAP: {'matched': 'cn=masters,cn=ipa,cn=etc,dc=rhevm3-beta,dc=gecco,dc=ch', 'desc': 'No such object'}
Shutting down
Shutting down dirsrv:
    RHEVM3-BETA-GECCO-CH...                                [  OK  ]
[root@rhevm3-beta log]#

*************************************************

 

Responses

This issue looks similar to the issue documented at:
http://www.mail-archive.com/freeipa-users@redhat.com/msg02058.html

Did your system hostname change? It looks like the directory server did come up, since the LDAP search is actually occuring, but not receiving the appropriate results.

not at all, I just do a fresh installation ( RHEL6.1 installation with yum install rhevm and rhevm-setup ) everything works ( from rhevm side ) and then a reboot.

 

I do the complete installation twice, the same problem.

 

--> you got it ! after setting the Hostname to FQDN in /etc/sysconfig/network it works !

 

thanks a lot

I folwed these instructions and modifiued the hostname in /etc/sysconfig network, and still can't start IPA after a reboot.

 

[root@phx2-dc-rhevmgr sysconfig]# cat network

 

NETWORKING=yes
HOSTNAME=phx2-dc-rhevmgr.cisco.com
GATEWAY=10.95.5.1


[root@phx2-dc-rhevmgr sysconfig]# service ipa start
Starting Directory Service
Starting dirsrv:
    PHX2-DC-RHEVMGR-CISCO-COM...                           [  OK  ]
Failed to read data from Directory Service: Unknown error when retrieving list of services from LDAP: {'matched': 'cn=masters,cn=ipa,cn=etc,dc=phx2-dc-rhevmgr,dc=cisco,dc=com', 'desc': 'No such object'}
Shutting down
Shutting down dirsrv:
    PHX2-DC-RHEVMGR-CISCO-COM...                 
  

 

Decided to try rebooting one more time - and that did the trick.

[root@phx2-dc-rhevmgr ~]# ipactl -d start

Starting Directory Service
Starting dirsrv:
    PHX2-DC-RHEVMGR-CISCO-COM... already running           [  OK  ]
Starting KDC Service
Starting Kerberos 5 KDC:
Starting KPASSWD Service
Starting ipa_kpasswd:
Starting HTTP Service
Starting httpd:
[root@phx2-dc-rhevmgr ~]# ipactl -d status
Directory Service: RUNNING
KDC Service: RUNNING
KPASSWD Service: RUNNING
HTTP Service: RUNNING
[root@phx2-dc-rhevmgr ~]#

I'm assuming IPA was installed/triggered by RHEV itself, and not as an "external" standalone IPA installation?

 

Andrius

Red Hat, Inc.

Also, the RHEV-H host install looks like a separate issue. Did you try to re-add it right after the first failure?

After speaking to RHEV Engineering, this is a known issue and already logged in Bugzilla. The current requirement is to use a FQDN rather than just a hostname. This is currently being evaluated.

 

https://bugzilla.redhat.com/show_bug.cgi?id=733328

 

Hope this helps!

 

Regards,

 

Andrius

Red Hat, Inc.

Side point, but could you (meaning RedHat generally, not you personally) please stop flagging bugs like this as secret?

 

There's no security disclosure issue in IPA requiring a FDQN, so hiding these bugs from public view just antagonisises customers for no good reason.

 

It would also be nice to have RHEV entered into the bugzilla product list, so that we can file bugs directly there rather than clogging up the users group.

 

Thanks.

James, this is completely unintentional. We are planning on opening up the RHEV product in Bugzilla soon. Stay tuned!