Setting up RHEL 8.4 with minimal installation and DISA STiG fails

Latest response

Using RHEL 8.4 Binary ISO we try to create a new local VM with Minimal Install, DISA STIG Security Policy and Installation Destination created as per attached images (RHEL84InstallationSummary.PNG and RHEL84ManualPartitioning.PNG). When we proceed with the installation it reports an error stating message "The following software marked for installation has errors. This is likely caused by an error with your installation source" (See image RHEL84InstallationError.PNG).

I have used the same ISO and setup RHEL 8.4 with same configuration earlier. But now, with even downloading the latest ISO it gives me the same error consistently.
Installation Summary screenManual Partitioning screenInstallation Error

Responses

Hello Amitsingh Pardesi,

The images you mentioned are not visible.

Regards,
RJ

I re-posted as earlier I missed to insert the images.

I'll test this on my own lab

Regrards,
RJ

Hello again Amitsingh Pardesi,

I didn't see the PNG images you mentioned (RHEL84InstallationError.PNG and RHEL84ManualPartitioning.PNG), available in your original post, so I went ahead and used my own RHEL 8.4 DVD and evaluated this, and it worked for me selecting the DISA STIG Security Profile. I used "minimal install" for the package selection, made all the required partitions it calls for and I had no issue. It's interesting the installer won't allow continuing without making all the proper partitions (as you already know).

I could not replicate the issue you had with a fresh download of the RHEL 8.4 DVD (sha256sum matches the block of text below). Like your example, I also did this on a virtual lab, using the DVD ISO file below with minimal install and again, it worked fine for me. I clicked the "finished" button, the system rebooted as expected and I saw the expected text banner and login prompt. I logged in with no issue.

I recognize you faced this problem, however I couldn't replicate the issue, even with minimal package selection on a virtual system. Please (see my DVD sha256sum below). My DVD matches the SHA256SUM from the download page, and if yours matches, maybe there's a different issue, but I believe the RHEL 8.4 ISO works because I just ran this successfully and could not replicate the issue you mentioned using similar conditions.

# sha256sum rhel-8.4-x86_64-dvd.iso
48f955712454c32718dcde858dea5aca574376a1d7a4b0ed6908ac0b85597811  rhel-8.4-x86_64-dvd.iso

From the download page: Red Hat Enterprise Linux 8.4 Binary DVD

    Red Hat Enterprise Linux 8.4 Binary DVD
    Last modified: 2021-05-18 SHA-256 Checksum: 
    48f955712454c32718dcde858dea5aca574376a1d7a4b0ed6908ac0b85597811

Perhaps try. re-downloading the ISO file and or at minimum verify the SHA256sum matches for RHEL 8.4 - I say this because while you have used the iso previously, I just did this and could not replicate the same issue. If the issue persists, then that would certainly be odd, and I'd recommend a case. with Red Hat if a new ISO file fails yet again in your next attempt. If you do open a case, please mention this discussion as a link.

Kind Regards,
RJ

I will get the SHA256SUM and post

PS C:\WINDOWS\system32> Get-FileHash "F:\Work\VMWare\Shared VMs\rhel-8.4-x86_64-dvd.iso" -Algorithm SHA256 | Format-List

Algorithm : SHA256

Hash : 48F955712454C32718DCDE858DEA5ACA574376A1D7A4B0ED6908AC0B85597811

Path : F:\Work\VMWare\Shared VMs\rhel-8.4-x86_64-dvd.iso

Good day to you Amitsingh Pardesi,

It looks like the SHA-256 sum matches. This is odd and not immediately explainable. I can say it worked in my case as mentioned above, following the conditions you mentioned.

I recommend submitting a case with Red Hat. However, is there any possibility the drive pool you're installing this is 100% full? The drive pool being where the storage for your virtual system resides?

I've seen snapshots in (for example) VMware from other systems fill up a drive pool, and while the systems themselves will show what seems to be a not-full condition with rounds of the df command, the underlying drive pool being full causes undesired errors. Just a thought, I'm not necessarily saying it is that.

Unless I've missed something and someone else can chime in here.

Kind Regards,
RJ

By drive pool, if you mean the underlying storage drive where the VM is created the the answer is no. I have over 250GB of free space on the drive where I create the VM image. And I am allocating the VM with 50 GB disk space that gets allocated as required on single disk.

I am installing this locally using VMWare Workstation Pro v16 with the hardware config as below: Memory - 8 GB Processors - 2 single core Hard Disk - 50 GB Network Adapter - NAT

And thank you RJ for looking into the issue.

Understood...

This seems odd, and bears further research (not to be overly-obvious). I'm not clear how/why it worked for me, and not for you using similar conditions.

How big is the footprint of the vmdk (or whatever disk type) you are using for this specific system (for the "disk "of the system being built)?

Regards,
RJ

The footprint is not too large. Its just about 3.7 GB.

BTW, I tried re-creating the VM with same configuration as shared earlier. And this time it worked. Not sure, why but happy that RHEL 8.4 with minimal install and DISA STIG profile got installed. Verified the login and internet connection (over DHCP) works only after I disable the firewall.

The point to note is, today I tried thrice with different network connection to get the base image installed but it failed with exact same error. I observed that during installation while getting the abrt-desktop-2.10.9-20 package (37/470, I guess) it fails to procure its dependencies and fails. Now whether this happens because of the mirror it connects to or due to some other external issue, I could not deduce. But the error is pretty consistent. So far I had attempted to get RHEL 8.4 with same configuration setup on 4 different laptops (all Thinkpad T450/T470 with 16GB RAM) and at least 8 to 10 times on each laptop. But was successful only thrice on 2 different laptops. 2nd time on same laptop for the first time today just a while back.

This is very odd issue that I have faced while setting up RHEL 8.4 with DISA STIG security profile. Though same ISO gets the server install with default security profile installed successfully consistently.

As I have my base image created, I am good to move ahead with my work.

Thank you RJ for your time and suggestions.

I'm glad you got this to work finally Amitsingh Pardesi

Regards,
RJ