Default Available PostgreSQL in RHEL 7 Workstation

Posted on

Hello,

The default available PostgreSQL RPM postgresql-server-9.2.24-7.el7_9.x86_64 appears to not allow updating/upgrading to a newer/patched version - when the standard rhel-7-workstation-rpms is being used.

A couple of questions:
• Why is this version not able to receive updates/patching from the default RPM repo?
• If I enable the RHSCL repo for 'RH Workstation', download a Red Hat 'curated' version of PostgreSQL (rh-postgresql-*), do those versions of Postgres provide regular security errata/upgrades?

The default postgresql-server-9.2.24-7.el7_9.x86_64 comes up with vulns and being unable to go any higher as it sits provides a challenge.

Unfortunately, an underlying third-party app requires it to be present for functionality. The thought is replacing it with one of the current RHSCL versions and symlink to that instead.