install python-mysql-connector

Latest response

HI

am facing the below error while installing the mysql-connector-python.x86_64.

Error


Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package mysql-connector-python.x86_64 0:8.0.20-1.el8 will be installed
--> Processing Dependency: mysql-connector-python-cext = 8.0.20-1.el8 for package: mysql-connector-python-8.0.20-1.el8.x86_64
--> Running transaction check
---> Package mysql-connector-python-cext.x86_64 0:8.0.20-1.el8 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.21)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.20)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.9)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.8)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libssl.so.1.1(OPENSSL_1_1_1)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libssl.so.1.1(OPENSSL_1_1_0)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.28)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libssl.so.1.1()(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libcrypto.so.1.1()(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Finished Dependency Resolution
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libssl.so.1.1(OPENSSL_1_1_0)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libcrypto.so.1.1()(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libc.so.6(GLIBC_2.28)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libssl.so.1.1(OPENSSL_1_1_1)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libcrypto.so.1.1(OPENSSL_1_1_1)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libstdc++.so.6(CXXABI_1.3.9)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libssl.so.1.1()(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libstdc++.so.6(CXXABI_1.3.8)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit)


Dependency resolving failed due to missing dependencies.
Some repositories on your system are disabled, but yum can enable them
and search for missing dependencies. This will require downloading
metadata for disabled repositories and may take some time and traffic.


Enable all repositories and try again? [y/N]: y
--> Running transaction check
---> Package mysql-connector-python-cext.x86_64 0:8.0.20-1.el8 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.21)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.20)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.9)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.8)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libssl.so.1.1(OPENSSL_1_1_1)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libssl.so.1.1(OPENSSL_1_1_0)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.28)(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libssl.so.1.1()(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Processing Dependency: libcrypto.so.1.1()(64bit) for package: mysql-connector-python-cext-8.0.20-1.el8.x86_64
--> Finished Dependency Resolution
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libssl.so.1.1(OPENSSL_1_1_0)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libcrypto.so.1.1()(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libc.so.6(GLIBC_2.28)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libssl.so.1.1(OPENSSL_1_1_1)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libcrypto.so.1.1(OPENSSL_1_1_1)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libstdc++.so.6(CXXABI_1.3.9)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libssl.so.1.1()(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libstdc++.so.6(CXXABI_1.3.8)(64bit)
Error: Package: mysql-connector-python-cext-8.0.20-1.el8.x86_64 (mysql-connectors-community)
Requires: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Responses

try cat /etc/*release
yum clean all
yum repolist enabled
to check the repos match the rhel version