System not registered notifications

Latest response


I constantly receive notifications saying "the system is not registered" but my system is registered.
See the attached screenshot.

I also verified in the command line with subscription-manager.

What do I have to do to make it stop ?




Hi Daniel,

It might be a temporary issue ... if it persists, I recommend to contact the Red Hat Customer Service team.
What you can try would be to unregister and re-register the system, possibly it may resolve the problem. :)


Hi Christian,

Thank you for your response. I did try to unregister/register (which was ended OK) but still...

I think I have this problem since the upgrade RHEL 8.1 to 8.2, and I thought it wouldn't last more than a couple of weeks.

My account doesn't have credentials to have direct support and I didn't want to annoy my sysadmins. I'll wait a bit before asking them -we are all remotely working from now on and they have a lot on their plate- or contact Red Hat Customer Service later.

Thanks again and have a nice day.

Best regards, Daniel

You're welcome, Daniel ! Wish you the same : have a nice day - and I hope that Customer Service can solve it. :)


Hi Christian,

For your infortation, Customer Service thought that it could be because I only have the "download apps and updates" right and not "manage subscription", but one of our org admin has all the rights and has the same problem with his machine. Someday , we'll have a local Satellite subscription server, we hope that it will end it. Otherwise I hope that an upcoming update could solve it.

Thank you anyways.

Best regards,


Hi Daniel, I have the same problem with fresh installation of RHEL 8.2. I try unregister/register again by CLI and GUI but still the message. Could you fix this problem?


Hi Reinaldo,

I don't have a solution for the moment. I will post in this discussion when I get one.


Hi Daniel,

Is the server attached to a Satellite or directly to CDN?

If possible run the commands below, or ask a system administrator to do it for you:

  • subscription-manager unregister
  • login to RH Satellite or customer portal
    • check if the server name is removed from inventory, if not remove it manually
  • subscription-manager register

See if this works for you


Jan Gerrit

Hi Jan,

The system is not yet attached to a Satellite so it is registered with CDN.

I followed your advices : I unregistered the system with subscription-manager CLI I deleted the server from the Web inventory

From CLI subscription-manager registered and insights-client --register

The system is back in the inventory, but still the same problem : I get notifications for "System is not registered". In the parameters GUI system is shown not registered but when I used the register window (see my screenshot in the first post) to register from Red Hat registration server it cannot register because the system is already registered.


Our systems are connected to Satellite and even registered to Insights via Satellite and further, the hosts are even listed in and I still get the notification. I was hoping for a solution from a web search (hence I ended up here) but looks like I will need to log a job.

Solution from Red Hat Support: Rename/Remove the file - /etc/insights-client/insights-client.motd Just to clarify, I was getting this notification when I logged on via SSH, in addition to my own banner/motd.

This system is not registered to Red Hat Insights. See
To register this system, run: insights-client --register

Client was registered and working fine with Satellite and Cloud Insights. And no GUI installed, so can't speak to that.

I am getting the exact same issue. I get a message saying

This system is not registered to Red Hat Insights. See To register this system, run: insights --register

When I run the command in the terminal it says:

This host has already been registered. Automatic scheduling for Insights has been enabled. Successfully uploaded report View the Red Hat Insights console at View details about this system on

Please advise?

Any resolution to this problem yet? I tried Peter's temp solution by renaming "/etc/insights-client/insights-client.motd" and it worked even after the reboot.

RHAT .. let us know please.

Doesn't work for me...

If you need help from Red Hat open a support case here.

This is a customers/volunteers forum.

My institution did open a support case (#02686726) in May 2020, no evolution since.

Maybe contact Red Hat and ask them for an update on the case. Sometimes you can chat online with Red Hat in the Customer Portal area location where you view your cases.


I have the same issued with my Rhel 8.2 and now upgraded to 8.3 issue still persists.

I am going to open a case on this as well.

I was hoping that it would be gone with RHEL 8.3...

Hope this helps From Rh on my case. Hello,

My name is Amar and I would be assisting you during this service request.

This is a known issue and is tracked under Red Hat Bug 1806156 (

As a workaround follow the below step:

unlink /etc/motd.d/insights-client

Regards, Amar Insights by Red Hat

Thanks Joseph, that's very kind of you. I previously moved /etc/insights-client/insights-client.motd to /etc/insights-client/insights-client.motd.bak

I now removed the link /etc/motd.d/insights-client Edit: changed link /etc/motd.d/insights-client -> /dev/null

But the notification pops up again!

I think my problem is not related to insights-client but to subcription-manager (or gnome) In the GUI part, see my screenshot on top of this thread, it is available in parameters / details / About the soft says that the system is not registered but when I register it to Red Hat registration server or our satellite it yields "Failed to register: This system is already registered"

I even tried with phony custom address, login and password for the registration details, the error shows immediately, so I deduce that it doesn't even contact a regsitration server because it checks the registration status before contacting a registration server.

First I removed cockpit, then subscription-manager-cockpit, but nothing changed and notifications kept popping.

Today I upgraded to RHEL 8.3 and there are no more notifications!

/etc/insights-client/insights-client.motd is back

so to put things straight I relinked /etc/motd.d/insights-client -> /etc/insights-client/insights-client.motd

I just updated to 8.3 and insights client was updated but MOTD is still there.

insights-client --version Client: 3.1.0 Core: 3.0.196-1

Red Hat Enterprise Linux release 8.3 (Ootpa)

lrwxrwxrwx. 1 root root 41 Oct 28 23:41 /etc/motd.d/insights-client -> /etc/insights-client/insights-client.motd

Still there (as I moved it, it came back) but no more annoyance for me since upgrade to RHEL 8.3