System not registered Error since Upgrade to RHEL 8.2

Latest response

I have a free RHEL 8 Developer license for almost a year. This ends at the end of June. Yesterday I upgraded from RHEL 8.1 to RHEL 8.2. Since then I have received constant notifications, that my system is not registered and that I can therefore not receive any updates! Also in the GNOME settings, menu item "Info", it says that the system is not registered. When I click on "Register"-Button, there comes the message, that the system is already registered! My system is also correctly displayed as registered and active in my customer portal. I can also easily receive updates, that's not the problem. The very annoying problem is the constant pop-up notifications, that the system is NOT registered.

Several fresh clean-install did not help either, as did the manual removal and re-creation of the subscription management in the terminal with the following commands:

sudo subscription-manager remove --all
sudo subscription manager unregister
sudo subscription-manager clean

sudo subscription-manager register
sudo subscription-manager refresh
sudo subscription-manager attach --auto

What's going on there?



Hi Andreas,

Subscription issues are under support.

So you best open a support case to solve your issue.


Jan Gerrit

I have exactly the same issue and when I mailed to support, I got the reply that developer subscriptions are under self support and that I am on my own.... Very unprofessional from RedHat, imo.

Hi Marc,

Please check if what I wrote down below regarding "account types" is valid in your case. :)


I have no problem with my subscription, it's displayed correctly in my customer portal. I am sure that this is purely a technical problem in RHEL 8.2!

Compared to RHEL 8.1, a lot of visual changes were made regarding subscription management. When I install RHEL 8.1, there is absolutely no problem. But as soon as I run "dnf update" and is thus automatically updated to version 8.2, the correct subscription display in the system no longer works under Gnome. And every few minutes this message appears on the Gnome desktop. This is extremely annoying and prevents you from working.

So here's my question, what kind of technical problem can this be and whether this is known. Thank you and I hope for your understanding!

Hi Andreas,

Jan Gerrit is right ... you should either open a support case or contact the customer support team. From what I've read you tried
what you could do. I cannot reproduce what you have reported on any of my RHEL 8 servers. This is not a "normal experience." :)


Thanks Christian, then I'll do it like this

You're welcome, Andreas ! I wish you good luck ... I'm pretty sure they will get this issue sorted out. :)


Nope, obviously not in this life anymore ... it's October and it's still there. With my account as well as with new accounts ... it's so annoying ...

It's not the RHEL version number itself .... I still have an "old" ISO with RHEL 8.1 - if I install it, the subscription works fine! But as soon as I do the first update (in the terminal with "dnf update", so that I can see which packages are all updated), the package "subscription-manager" is also updated, and FROM THIS POINT the subscription no longer works! So, in my opinion, it's because of this one package.

As said above, I am having the same issue, so it must be some bug in RHEL 8.2. But the european support team refuses to take this to tech support, claiming that developer subscriptions are under self support. So to summarize, RedHat delivers a product which has issues and refuses to even accept the fact.

Did anyone find a solution to this? Or will the solution be to move away from RHEL?

Hi Marc,

Just to clarify ... it is not the product that has issues, your problem is related to contracting. Such administrative
things can get sorted out, I contacted the US support team several times, and they always solved these kind of
issues to my satisfaction. Important is to use a corporate account, no reason to "move away from Red Hat" ... :)


Thanks for your help, it's much appreciated. I logged in to the customer portal, but I don't see an account type option. Well, I tried to enter a support case, after entering all information I get this:

"You are not allowed to create case on this product."

So can not even create a support case.


Regarding Customer Support saying "developer subscription not being supported", make sure to register the system by using
a corporate account. When users register with a personal/private account, they receive this answer from Customer Support. :)


How can I find out which type of account I have? AFAIK, Developer subscriptions are always bound to a person?

Hi Marc,

Check, if you don't see a Red Hat account number there, you don't
have a corporate account. Additionally check your Personal Information site and if there is no
field that shows your company name - you most certainly have created a personal account. :)


I actually have an account number. So it should be a corporate account. Thanks!

Hi Marc,

Great ! Then registration and subscription related issues are supported.
I recommend to contact the US Customer Support team. Good luck ! :)

North America
1-888-REDHAT-1 or 1-919-754-3700, then select the Menu Prompt for Customer Service
Spanish: 1-888-REDHAT-1 Option 5 or 1-919-754-3700 Option 5
Fax: 919-754-3701 (General Corporate Fax)
Email address: 


Hello everyone! I have the same problem with the new OS 8.2 Did you solve it?

No, the problem / error is still there. Since February 2020! Please open a ticket in the customer portal and describe your problem there. The more users are affected and they report the problem, the sooner a solution may be found! Thank you!

I change now to CentOS. This is annoying.

RHEL 8.2 Needs to Release Fix Update

The problem is still there! Also in version 8.2. Even if you set up new accounts as a test and you try to register other systems with them, the same error! That can't be true anymore ...

Yes,I get this Problem Too,Even On Vrtual Machine Device Waiting 8.3 Release

This has nothing to do with the release, I am now firmly convinced that the problem will still exist under RHEL 8.99 ... it is due to the subscription management of Red Hat.

Yes, this is getting super annoying and I wonder why RedHat let's down developer like they do. They should care about developers using RedHat for thei day to day work, yet they don't. RedHat gives away a free developer subscription which does not work for months, and, which you have to renew every year in an obscure and often non-working way.

The RHEL 8 developer edition has become a big joke, but not a good joke, nobody laughs.

You are so right Marc! Meanwhile I work on Fedora because CentOS has a serious update problem, but that's not the same thing ... And personally, I no longer believe that anything will change or even improve here. I think they are trying to use such subtle methods to push people into paid licenses.

RHEL 8.3 was released recently, but this annoying bug is still there. Someone from RedHat actually listening to the community?

It's not the RHEL version number itself .... I still have an "old" ISO with RHEL 8.1 - if I install it, the subscription works fine! But as soon as I do the first update (in the terminal with "dnf update", so that I can see which packages are all updated), the package "subscription-manager" is also updated, and FROM THIS POINT the subscription no longer works! So, in my opinion, it's because of this one package.