SSL peer rejected your certificate as expired on Google Cloud

Latest response

I'm using Red hat 7 image from Google cloud
this link: https://console.cloud.google.com/marketplace/details/cognosys-public/hardened-red-hat-enterprise-linux-7?q=cognosys+REDHAT+7.3

however, I could neither yum update nor yum install any lib or packages. It keep say that " https://cds.rhel.updates.googlecloud.com/pulp/repos/content/dist/rhel/rhui/server/7/7Server/x86_64/extras/os/repodata/repomd.xml: [Errno 14] curl#58 - "SSL peer rejected your certificate as expired."
Trying other mirror. " Anyone have any idea ?

Responses

Hi Torpong,

Did you get any help for this? I have the same and absolutely no idea where to find any kind of help

Hi Torpong, I would like to ask, please, if have you tried the following solution: https://access.redhat.com/solutions/3167021 "Resolution You need to update the RHUI certificate using the Microsoft-provided RPM. RHEL 7:

$ curl -o azureclient.rpm https://rhui-1.microsoft.com/pulp/repos/microsoft-azure-rhel7/Packages/r/rhui-azure-rhel7-2.2-97.noarch.rpm $ sudo rpm -U azureclient.rpm $ sudo yum clean all

Could you please try and let me know if it results? Many thanks.

Hi Eliane,

Thanks for this but this seems to be for an instance in Azure and I'm looking for the same for GCP.

Hi Aki, Thanks a lot for your reply. I have a similar suggestion, for GCP:

$yum install google-rhui-client-rhel7.noarch {curl -o google-rhui-client-rhel7.noarch.rpm https://packages.cloud.google.com/yum/repos/google-compute-engine-el7-x86_64-stable/Packages/af6e12fec32cbc7d4268bc6b9f31eba1a8097407d0b6c3995b74b936fd80eb46-google-rhui-client-rhel7-7.0-1.noarch.rpm}

$sudo rpm -U google-rhui-client-rhel7.noarch.rpm"

$sudo yum clean all

$yum update

Hi Eliane, Thanks for your help. It looks like we're getting close now. Now the error changed into: failure: repodata/repomd.xml from rhui-rhel-7-server-rhui-optional-rpms: [Errno 256] No more mirrors to try. https://cds.rhel.updates.googlecloud.com/pulp/repos/content/dist/rhel/rhui/server/7/%24releasever/x86_64/optional/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found By the way installing the rhui-client package I got errors: /bin/bash is needed by google-rhui-client-rhel7-7.0-1.noarch /bin/sh is needed by google-rhui-client-rhel7-7.0-1.noarch yum is needed by google-rhui-client-rhel7-7.0-1.noarch Did the install with --nodeps but actually this was the original reason this whole exercise using yum. This instance was deployed using GCP public RHEL image which seems not to have a traditional rpm- database from which used for dependence queries.

Hi Aki, Thanks for your reply. I spoke with the team and they informed that is definitely a google cloud issue. Would be possible to open a ticket with them to get this solved?

Many thanks for your response.