libelf.so.1: wrong ELF class: ELFCLASS64

Latest response

Hi! Thanks for any help provided!

I'm running redhat linux 7.6 and am trying to run spectre from cadence it is an x86 software.

Also I have installed elfutils, elfutil-devel, and elfutil-libelf with no luck of getting past this error. libelf.so.1 is located in the lib64 folder one suggestion was to move it to the lib folder I tried that before realizing it's the same as changing the environment path.

Any suggestions? Thanks again for any help offered!
CW

Responses

You need the i686 versions, eg. elfutil-devel.i686

Awesome! Installing "elfutils-devel.i686" did the trick!