RHEL 8 install hung at "Installing boot loader" on HP Z2

Latest response

On a new HP Z2 G4 workstation, I'm trying to install RHEL 8 from a usb stick with the full dvd iso on it. The installation gui proceeds until at the bottom it says:

Installing boot loader

at which point it is hung.

I tried completely erasing the partitions using gparted and trying again, but the same thing happens. Gparted had no complaints about writing a new partition table, either msdos or gpt.

Previous steps to get the usb stick to even boot included disabling Secure Boot in the BIOS and leaving 'legacy' booting disabled.

Suggestions?

Responses

Hi, I am facing the same problem. New HP Z2 G4. I checked that it is certified for RHEL 8. The installer hangs at the time of installing boot loader. Same issue with RHEL 7.6.

Is this a BIOS setting issue?

Regards

RHEL 7.5 installed successfully - so basically you have to install the exact version that is on the HP Linux compatibility matrix for Z2.

I burned a double layer DVD for install media, turned off UEFI in the BIOS, and installed via legacy boot and it mostly worked. Hung at the reboot after install, but seemed a minor shutdown issue.

But it's frustrating to have to disable UEFI and I wonder how long computers, HP's in particular, will have that as a boot option. And I don't know what the consequences are to not have UEFI turned on.

I'm going to try some more things, like manually doing the partitions at install time to see if I can get UEFI to work.

Hi,

I tried manual partitions ... nothing worked. But RHEL 7.5 installed without a problem. HP Z2 compatibility says 7.5 or higher - but only 7.5 works, as I tried to install 7.6 and 8.0, both froze at the boot loader installation.

I believe you can enable UFEI after installation.

Regards

From dmidecode, what version of system firmware (BIOS) do you have on your HP Z2 G4?

Although, it's less likely to matter, do you have the tower or "small form factor" variant?

I have seen at least one report of such a hang during install which occurs when efibootmgr is attempting to write the EFI boot variable for the newly installed system. But I can't reproduce the problem when installing either RHEL-8.0.0 or RHEL-7.7 on the HP Z2 SFF G4 Workstation which I tested.

I suspect, without proof, that there is some interaction between kernel versions and the system firmware (BIOS) on that system.

Go to the HP support website and download and install the latest system BIOS. Currently this appears to be 01.05.05 Rev.A. You should be able to do an firmware update directly from the BIOS over the network to HP.

BTW, you can't switch a RHEL install from legacy BIOS to UEFI once it's done. A UEFI boot requires a UEFI "system partition" and GPT partitioning (vs. MBR) on your boot device. Among other things, this contains the UEFI version of the grub boot loader. A RHEL installation will not create the GPT UEFI "system partition" on system which is running in legacy BIOS mode. So even though you can switch the system between UEFI and legacy-BIOS mode, a RHEL installation is tailored for only one of those boot methods.

-Lenny.