Upgrade to RHEL 8

Latest response

Hello!
I try to upgrade my RHEL 7 (7.6) to the latest version.
After running leapp upgrade I got the next error:
[ERROR] Actor: prepare_upgrade_transaction Message: A Leapp Command Error occurred.

cat /var/log/leapp/leapp-report.txt
Severity: high
Title: Packages will not be installed
Summary: 10 packages will not be installed due to blacklisted repositories:
- rpcgen
- javapackages-filesystem
- rpcsvc-proto-devel
- python3-httplib2
- ldns-utils
- ivy-local
- libnsl2-devel
- python3-pyxattr
- gdk-pixbuf2-xlib
- python3-javapackages

What does it mean?
I have Red Hat Developer Suite subscription.
Best regards, Igor Bursin.

Responses

Hi Igor,

Please do NOT try to upgrade from RHEL 7 to RHEL 8 ... too many important things changed under the hood.
Please backup your personal data, perform a fresh installation of RHEL 8 and restore back your personal data.
It takes way less time to cleanly install the new system than fixing the mess (if possible at all) after upgrade. :)

Regards,
Christian

Hi, Christian. Thank you for your answer. Unfortunately, at the moment I can't install RHEL 8 from scratch. I read the official documentation: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/upgrading_to_rhel_8/index. Upgrade from RHEL 7 to RHEL 8 is officially supported by Red Hat. Still, I would like to upgrade my system!

Best regards, Igor Bursin.

Hi Igor,

Officially supported ? Yes ... Possible ? Maybe ... Recommended ? Definitely NOT ! Well, it's up to you to decide. :)

Regards,
Christian

I haven't tried a RHEL7 to RHEL8 update yet but I imagine these packages are ones that the update process can't deal with. If you have noted Christian's warning, and have good plans on how to recover your server if the update fails, and still want to continue, you could try deleting those packages and put them back (if there are RHEL8 equivalents) after the update.

Hi, Michael! Thank you for your answer. These packages are not installed on my system! The leapp utility checks all packages in the system. If they are not installed from the RedHat official repositories, it advises them to be removed! I will continue investigations using the debug mode of the leapp utility.

Best regards, Igor Bursin.

My next guess would be that you have something installed that will require these extra packages when updated to the RHEL8 version. The one I checked isn't in the default 2 RHEL8 repos but seems to be in RHEL8 somewhere though I haven't traced it to a repo so far.

Yes, you are right! I found some useful information in debug logs. I reinstall some packages and remove some packages from rhel-7-server-eus-optional-rpms repostiory. After that the leapp utility was able to continue the upgrade process. Thanks for help... Best regards, Igor Bursin.

I started an update myself (of a clone of a RHEL7 VM) which seems to be working, but I looked at the /var/log/leapp/leapp-report.txt file before rebooting and it contained a similar message to your but with only 9 packages (omitting python3-httplib2) plus a message about possibly removing an EPEL package, but I wonder if all updates get warnings about these 9 packages.

If you can freshly install a RHEL machine than that is always the most advisable way instead of upgrading one from 7 to 8.

I completely agree with Christian Labisch (and Christiaan Van Aken too).

I've seen utilities that allow an upgrade from one major version of Red Hat Linux to another. While it is possible and they give documentation, I recommend against it. However, if (anyone landing at this discussion) really does attempt this, I'd recommend doing it on a virtual system that you can clone or at minimum snapshot first. **Verify your ability to restore from the snapshot exists, and that you are working from the clone (run sys-unconfig and make sure the ssh host keys are different among other things such as IP address, MAC address).

I've seen people attempt upgrades of major releases, and while the odds of success are better than you'd get in Las Vegas, it's still incredibly risky. If anyone reading this actually attempts to do such an upgrade, be prepared in advance to build a new system that can fulfill the role of the server you are doing this on - just in case it goes poorly. I've seen enough examples in my history in this discussion forum of doing an upgrade from one major release to another to where I recommend against it.

All that said, if anyone does attempt it, I hope it goes well, and please take your time to have a realistic attainable contingency plan just in case.

Regards

RJ

Hi RJ,

I'm glad that a honorable person like you is with me ... even though you've misspelled my name ... :D :D :D

Cheers :)
Christian

Whoops! thanks! corrected

RJ

My update did work, though the instructions say to run subscription-manager release --set 7.6 beforehand, which was still set after the upgrade and prevented dnf working which I fixed by subscription-manager release --unset. It also puts a splash screen on each boot about the license and subscription, both of which are valid, which I haven't fixed yet.

Hi Michael,

Glad it (somehow) worked for you, but still I recommend against it - (hidden) issues may appear later on ... :)

Regards,
Christian

It is a disposable test VM, so I am not worried. My splash screen issue looks to be a difference between RHEL7 and RHEL8 systemd set up, and fixed for me by systemctl disable initial-setup-reconfiguration.service

Michael,

I'm very glad it worked for you. Perhaps they've improved the process. Anyone who lands here with the intention of going from RHEL 7.x to 8.x - make sure you have a contingency plan just in case, especially if it is a critical or production server.

Regards

RJ

For all members who land on this discussion thread ... to give you a clue why it's recommended to freshly install RHEL 8 :
Here is the publication of the CentOS team, explaining the procedure of creating the new CentOS 8 system - excerpt ->

"A CentOS major release takes a lot of planning and changes in tooling as it is based on a much newer version of Fedora than previous versions. This means that everything from the installer, packages, packaging, and build systems need major overhauls to work with the newer OS. This means that there is always a ramp up period depending on the changes needed to make a rebuild work."

"The differences between EL-8 and EL-7 are no exception as the kernel has changed drastically, the repository format has added 'modules' and RPMS have grown many features that EL7 and before do not have. About the only item which has not drastically changed between EL7 and EL8 is the init system which is still systemd."

Regards,
Christian

how did you get past rpcgen and rpcsvc-proto-devel since they are splitting away from glibc-common and glibc-headers?

One of the disadvantages of using the leapp tool to upgrade from RHEL7 to RHEL8 is you won't know for sure the answer to questions like that without trying it or asking it in a support case. I didn't have /bin/rpcgen after I upgraded a test server from RHEL7 to RHEL8 but your set up is probably different to mine so you might see something different if your upgrade is successful at all.