RHEL 7 server not seeing most current packages available on Satellite 5.7 / cant install errata

Latest response

Hello All,

I'm having numerous issues with my RHEL servers installing errata, bug fixes and software updates available from our Satellite server.
For example, according to satellite, I have a package I need to updated called systemd-sysv-219-57.el7_5.3.x86_64.rpm on one of my host.
When I try to push the update I get a failed response with "Error while executing packages action: empty transaction [[6]]".

When I go onto the server itself and run yum update systemd-sysv, i get response: This system is receiving updates from RHN Classic or Red Hat Satellite.
No packages marked for update

If I try to do yum install systemd-sysv, I get response: This system is receiving updates from RHN Classic or Red Hat Satellite.
Package systemd-sysv-219-57.el7_5.1.x86_64 already installed and latest version
Nothing to do

As you can see the current version is 5.1 but the Satellite server says I need to upgrade to 5.3 so I'm not really sure why they are not talking correctly. This is not happening for all packages/errata but its happening for quite a few.
Furthermore, when I run yum update I only see about 5 items that need to be updated but satellite tells me about 28+ items need to be updated. Not sure why there is a discrepancy.

Things I have tried:
checked /etc/yum.conf - to ensure nothing is excluded

checked yum repolist - to ensure the system is subscribed to the correct channels

Ensured rhn-client-tools and yum-rhn-plugin are at latest version

Deleted system from Satellite and re-registered it

Tried enabling and disabling /etc/yum/pluginconf.d/rhnplugin.conf

I tried - rhn-profile-sync.

Using command- rhn_check -vvv doesnt help very much as it says the same error but no details as to why.

yum clean all

Let me know wat you think

Responses

I suspect you are troubleshooting the wrong end of the connection - this problem is not caused by the satellite client, but rather the "yum metadata" files ("repomd.xml" file for each channel) on the Satellite server are not being regenerated correctly. Thus, every time your RHEL 7 client connects and downloads that file, it gets old/bad data. But in the Satellite GUI, you can see channels and packages based on the contents of the Satellite database, not the 'repomd.xml' files (so you can see the new version of 'systemd-sysv...', you just can't get to it via "yum").

I've been on Satellite 6.x for a couple of years now, so unfortunately I've already forgotten much of my "Satellite 5 Fu" and all I can offer you is hints to resolve the problem. There is a batch process manager (with a vaguely goofy name, though I can't recall it) that may need to be restarted - it is one of the six or so services that make up the complete "satellite-service" stack. Or a complete "satellite-service restart" would do it.

You may also need to clean up some stale temporary files in the directories where the "repomd.xml" files for each channel are kept on the Satellite server (/var/rhn/something?). They will have *.NEW file names; if they are more than about 15-20 minutes old, that means the process of generating them has failed, and they should just be deleted.

Thanks for the response, ill have to reach out to our satellite administrator as I don't have full access to the server. I will post back with the results.

Hello All, The Satellite Server admin rebuilt the channel cache and I ran a yum clean all and yum repolist all on the client and everything is now working. I referenced this article https://access.redhat.com/solutions/19303 for the server side and the steps taken resolved the issue. Thanks all