Disconnected Satellite 6.3 / Registered RHEL 7.5 Client repomd.xml not found

Latest response

Hello,

I have a disconnected Satellite 6.3.1 running. I imported content from a "swing" server. The Sync was successful. I'm using the Default Org and Default CV. I'm running VMware Hypervisors so I installed virt-who on the Sat server and discovered all my ESXi hosts. I assigned each Content Host (ESXi) a RHEL for VDC STD subscription and a Smart Mgmt for Unlimited Guests sub. Everything is registered.

I created an activation key with NO subscriptions. For Repo sets on the activation key, I did enabled all the RHEL 7 repos (optional, extras, supplementary, common, etc.) The RHEL 7 Base was already enabled by default.

I deployed a RHEL 7.5 server and registered the machine. It appeared to register ok. A subscription-manager status is Current and the WebUI shows the hosts as registered (katello-client not installed at this point). subscription-manager repos command shows all the repos i enabled in the activation key show as enabled on the client.

I ran rm -rf /var/cache/yum/* | yum clean all, then a did a yum repolist. The result was the image attached.

I checked out the article as suggested, which lead me here https://access.redhat.com/solutions/2802131

As suggested I inspected /var/lib/pulp/published/ and noticed folders/repos were missing, specifically the once that are erring out in the attached image. This leads me to believe that these repos have not been published (which is weird considering its the Default Org and CV) or the repos are corrupt.

I ran a full sync on one of the problem repos, which was successful (according to the web interface), then on the client I cleared yum cache and checked again, no change, same errors.

Any thoughts on this?

Responses

Tim, just as a check, please rule out this solution id https://access.redhat.com/solutions/2850911

Did you publish & presented the content view for your systems?

Let us know how this goes, someone ought to chime in.

Regards,

RJ

I made activation keys for servers, workstations. We still have a smattering of RHEL 6 servers, mostly RHEL 7 servers, and 7 workstations. The activation keys assign the channels in our case. (this is just for reference).

The issue you're experiencing I've seen in that solution ID I posted. Some security settings for common security configurations have one set repo_gpgcheck to 1 (which fails) however you might be facing a different issue.

let us know

RJ

Hello Tim,

I do not see the picture, could you add the error as inline text?

Regards,

Jan Gerrit

Hey all,

sorry about the attachment, I thought it actually attached. I added it below (I think) as inline text. R. Hinton, I'll check out the article you provided and update with results.

rhel-7-server-devtools-rpms                                                                         2.3 kB  00:00:00
rhel-7-server-extras-rpms                                                                           2.0 kB  00:00:00
<FQDN Disconnected Satellite Server>/pulp/repos/Default_Organization/Library/content/dist/rhel/server/7/7Server/x86_64/optional/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
<FQDN Disconnected Satellite Server>/pulp/repos/Default_Organization/Library/content/dist/rhel/server/7/7Server/x86_64/rh-common/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
<FQDN Disconnected Satellite Server>/pulp/repos/Default_Organization/Library/content/dist/rhel/server/7/7Server/x86_64/rhn-tools/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
<FQDN Disconnected Satellite Server>/pulp/repos/Default_Organization/Library/content/dist/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
<FQDN Disconnected Satellite Server>/pulp/repos/Default_Organization/Library/content/dist/rhel/server/7/7Server/x86_64/supplementary/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
<FQDN Disconnected Satellite Server>/pulp/repos/Default_Organization/Library/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

repo id                                             repo name                                                                                           status
!rhel-7-server-devtools-rpms/x86_64                 Red Hat Developer Tools RPMs for Red Hat Enterprise Linux 7 Server                                  1,452
rhel-7-server-extras-rpms/7Server/x86_64            Red Hat Enterprise Linux 7 Server - Extras (RPMS)                                                     875
rhel-7-server-optional-rpms/7Server/x86_64          Red Hat Enterprise Linux 7 Server - Optional (RPMS)                                                     0
rhel-7-server-rh-common-rpms/7Server/x86_64         Red Hat Enterprise Linux 7 Server - RH Common (RPMS)                                                    0
rhel-7-server-rhn-tools-rpms/7Server/x86_64         RHN Tools for Red Hat Enterprise Linux 7 Server (RPMS)                                                  0
rhel-7-server-rpms/7Server/x86_64                   Red Hat Enterprise Linux 7 Server (RPMS)                                                                0
rhel-7-server-satellite-tools-6.3-rpms/x86_64       Red Hat Satellite Tools 6.3 (for RHEL 7 Server) (RPMS)                                                 80
rhel-7-server-supplementary-rpms/7Server/x86_64     Red Hat Enterprise Linux 7 Server - Supplementary (RPMS)                                                0
rhel-server-rhscl-7-rpms/7Server/x86_64             Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server                                 0

Ok, so on my RHEL 7 client, changing the /etc/yum.conf gpgcheck option to 0 does not change a thing.

Hi Tim,

repo_gpgcheck is the setting RJ is referring to. Did you check this?

Regards,

Jan Gerrit

on my client, in the /etc/yum.conf I do not see repo_gpgcheck at all, only gpgcheck. I changed gpgcheck to 0, it did nothing. I added repo_gpgcheck=0 and it also did nothing.

Tim, please validate/make sure "repo_gpgcheck=1" is not in the /etc/yum.conf earlier in the file to be 100% certain this issue is not causing the problem...

egrep repo_gpgcheck /etc/yum.conf

From the previous article I cited...

Root Cause
Currently Red Hat products (Customer Portal, Red Hat Satellite, 
RHUI..etc) does not support repo gpgcheck option yet.
Yum was trying to download repomd.xml.asc as repo_gpgcheck was set to 1. 
As yum was unable to locate repomd.xml.asc on the server due to 
GPG armor disabled, it was failing with [Errno 14] HTTPS 
Error 404 - Not Found error message.

I suspect you have checked this, but it is worthwhile enough to validate/rule out that this issue is not plagueing you with repo_gpgcheck=1 which will fail

Regards

RJ

Tim, I see your reply now...

You might have channel sync issues where something didn't come down right, namely the directories with repomd xml files.

Perhaps do a manual synchronization, refresh your manifest. If needed, open a case with Red Hat.

Kind Regards

RJ

So it's been a few days. During this time, I decided to clear out my disconnected satellite of all repo content, export a fresh full copy of my Default_Org on my connected sat, and import it to my disconnected. To my surprise, I'm still getting the same errors. I did some quick research and it turns out the export I ran did not include repos such as rhel 7 optional, rh-common, rhn-tools, and the base rhel 7 repo. I'm not quite sure why. I ran the following command to perform the export

hammer content-view version export --id 1 (my Default_Organization CV)

Not sure why certain repos are not being included in the export....any thoughts?

So doing more research I noticed the HTTP error was potentially related to the specific repos I've enabled on my connected Sat server. I found this article https://access.redhat.com/articles/1586183 which provided some better insight on how to configure the repos I want. In my case, I'm going to disable all the minor release repos and enable only the 6Server and 7Server repos and try that. Stay tuned.

Let us know how that goes Tim.

I'm hoping you will be able (at some point) to enable 7.5 at minimum so you can get updates and especially relative bug fixes.

RJ

Hello, ok so I downloaded all the 6Server and 7Server repos and imported. Everything registered properly. The only thing is there are no repos for minor releases since everything is available in the 6/7Server repos. I don't think it's a big deal b/c we don't have EUS, and support is not interested in keeping servers at the same minor release when patching, so this will work out well. Thanks to everyone who contributed to this thread. Much appreciated!!