root authentication failure.

Latest response

I am trying to run yum to update to the latest versions of the software but when I "su - root" and enter the password I keep getting an authentication failure error. I am confident I am typing in the right password. I also tried running yum under sudo but got an error message stating that my login is not stored in the sudoers file. When I initially tried to log into the root account I got a different message making reference to a file in etc/...... sorry, I didn't copy the file and location of that file. It also said that I had to reboot the system at that time which I did. Now I am getting the authentication failures.

Responses

hi James,

Is this on Red Hat 6 or 7? Would you mind gathering some more info, such as the error you mentioned? Both RHEL 6 and 7 are supported, I suspect you're using RHEL 7, but since RHEL 6 is Red Hat supported (6.8), not sure if you're using that.

I honestly don't know if this Red Hat solution https://access.redhat.com/solutions/22684 will help you or not (and it is for RHEL 6 or below), but it came up with a search regarding root password not working. Again, don't know if it fits with your system.

If you're in a hurry, you can submit a ticket directly with Red Hat.

Regards,

RJ

Hey I am using rhel 8.3 I am trying to login with root user by typing su - root ,but even if I type the correct password it shows authentication failure . I tried of changing the password i changed it but with the new password it's still showing authentication failure..how can I resolve this issue

Hi Mani Sharan,

Please try this Red Hat solution https://access.redhat.com/solutions/1276063 to start with, and let us know how this goes.

Hello James, we have not heard back from you, please see my two replies in this discussion, and the solutions.

Kind Regards,
RJ