Error when trying to enable repositories in Redhat Satellite 6.2.11

Latest response

Hi,

I needed quick help as stuck here from last one week.
My Satellite server is based on Red Hat Enterprise Linux Server release 7.4 (Maipo).
I am able to access it's Web-UI.
However when I try to enable any repositories under Content -> Red Hat Repositories, get Error as follows:

SSL_connect returned=1 errno=0 state=error: certificate verify failed

I have attached screenshot for reference.
When trying to enable from hammer CLI, getting below error:

Could not enable repository:
undefined method `default_capsule?' for nil:NilClass

Please note that certificates were generated at the time of installation and I have not used any customized certificates.

Are customized certificates mandatory for Satellite Server to function finely?

Thanks!!

Reference Screenshot

Responses

Hello Eystein,

This might sound a bit silly, but I would like you to run the following commands:

# yum clean all
# yum repolist

Once those run, try again to re-enable your repositories. The above is a quick fix for situations where your yum repository access is moved to a mirror that is being blocked by your firewall.

If that does not work, it's also possible that you have a proxy certificate configuration on your firewall. To verify that, please run the following:

# openssl s_client -connect www.redhat.com:443 -showcerts
ctrl+c to quit

It would be easiest to post your response, but you should expect to see the following header:

CONNECTED(00000003)
depth=2 C = US, O = "VeriSign, Inc.", OU = VeriSign Trust Network, OU = "(c) 2006 VeriSign, Inc. - For authorized use only", CN = VeriSign Class 3 Public Primary Certification Authority - G5
verify return:1
depth=1 C = US, O = Symantec Corporation, OU = Symantec Trust Network, CN = Symantec Class 3 EV SSL CA - G3
verify return:1
depth=0 1.3.6.1.4.1.311.60.2.1.3 = US, 1.3.6.1.4.1.311.60.2.1.2 = Delaware, businessCategory = Private Organization, serialNumber = 2945436, C = US, ST = North Carolina, L = Raleigh, O = "Red Hat, Inc.", OU = IT, CN = www.redhat.com
verify return:1
---
Certificate chain
 0 s:/1.3.6.1.4.1.311.60.2.1.3=US/1.3.6.1.4.1.311.60.2.1.2=Delaware/businessCategory=Private Organization/serialNumber=2945436/C=US/ST=North Carolina/L=Raleigh/O=Red Hat, Inc./OU=IT/CN=www.redhat.com
   i:/C=US/O=Symantec Corporation/OU=Symantec Trust Network/CN=Symantec Class 3 EV SSL CA - G3

If you see something else, there's a good chance that you have a proxy certificate server - in which case there are some special configurations you would need to do to get it working.

Let me know what the results are.

Thanks Matthew :) Seems like problem is resolved after rerunning the satellite installer with --force option. I am able to enable the repositories now. what do you think? this may have generated new certificates? which caused the issue to resolve?

The satellite-installer process performs a lot of checks and balances that cleans up the system. As far as certificates go, I don't think the issue is related to certificates at all (despite the SSL error).

My question would be what circumstances surrounded the issue. Was it - I installed satellite on Monday then I left for the day, came back this morning and ran into issues with configuration, or was it I installed satellite and immediately started configuring it?

I think that you should monitor it and see if the issue mysteriously appears again.

Yes absolutely, The issue dint come immediately. This is ongoing task from last few weeks as I am new to this. Will keep monitoring for this issue.

If the error resurfaces, I suggest trying to simply run the yum clean all / yum repolist combination. I had an issue once with, and the only fix was to add those commands into cron to run every hour. There's no guarantee it's an identical issue - but the symptoms are eerily similar.

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.