Yum repository not updating at the installation of RHEL server 7.3 : https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rt/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden

Latest response

Hello everyone,

I just installed the RHEL server 7.3 developper edition, i'm trying to update yum cache by taping: yum update, then faced the following issue:


# yum update
Modules complémentaires chargés : langpacks, product-id, search-disabled-repos,
: subscription-manager
https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rt/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Essai d'un autre miroir.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/solutions/69319

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

One of the configured repositories failed (Red Hat Enterprise Linux for Real Time Beta (RHEL 7 Server) (RPMs)),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=rhel-7-server-rt-beta-rpms ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable rhel-7-server-rt-beta-rpms
    or
        subscription-manager repos --disable=rhel-7-server-rt-beta-rpms

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=rhel-7-server-rt-beta-rpms.skip_if_unavailable=true

failure: repodata/repomd.xml from rhel-7-server-rt-beta-rpms: [Errno 256] No more mirrors to try.

https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rt/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden

I've already registred the installation and cleaned yum cache.

does anyone already faced this ?
thanks

Responses

Finally found it myself:

The third party repo: https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rt/os is generating the error. Certainly from subscribtion or certificate syncronisation problems. Find the redhat repos config files /etc/yum.repos.d/redhat.repo then disable the problem causing one, by setting enabled=0.

yum update

voilà !

Thanks very much, Newbie. So far, I've found 'open-source' potentially synonymous with "open-standards; possibly none at all!"

Redhat may be opensource but it's enterprise, which means it doesn't follow the normal release schedule of what normal open source would be. This is just very dissapointing considering people use Redhat specifically to negate dumb issues like this

how do i disable it can u please assist with command to do it thank you

Hi Jerry,

Open a terminal and execute this command to disable rhel-7-server-rt-beta-rpms :

sudo subscription-manager repos --disable=rhel-7-server-rt-beta-rpms

Regards,
Christian

Hi Christian

that command really fixed the issue, i can now do yum update

thank you

Hi Jerry,

You're welcome, I'm glad that I could give you a useful advice.

Cheers :)
Christian

Thank you very, Christain, It was really working for me too.

You're welcome Satish, I'm glad that it worked for you too. :)

Regards,
Christian

Thanks for this, much appreciated!

We're experiencing this as well, and it would be nice to see a fix come out. Why is some random 3rd party BETA repo enabled by default anyway?!

I think this may be an account issue. The RT channel shown above is for real time kernel which is available through developer subscription.

How do you tell what repository is giving you problems ?

Hi Steven,

This is a known thing which happens from time to time and was reported and discussed many times here - simply follow one of the suggestions and either disable the rt-beta repository temporarily or permanently by using one of the commands being provided in the message.

Regards,
Christian

This is an ongoing headache managing developers with VM's with frequent re-registering. If this repository is unreliable, I would like it to be disabled by default.

Taufiq Hasen, yeah, I faced the same hassle with one of my own Developer Suite systems. Christian, nice solution you posted, that was what I did to fix mine as well.

Thanks for your kind words RJ,
I'm glad you find it to be useful.

Regards,
Christian

Hi i had disabled it but still facing the same issue

[root@mavenserver yum.repos.d]# ping cdn.redhat.com ping: cdn.redhat.com: Name or service not known

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.