yum on new install gets HTTPS Error 403

Latest response

I am new to RHEL.

I recently installed a new machine and everything went well.
I installed several packages needed to build the code I was trying
to test on RHEL.

Then I convinced myself that I should repeat the install to show that I
could do it again from the notes I had taken.

No luck.

It took a while to figure out that I needed to remove the previous system
in the subscription list on the Customer Portal.

Once I did that I could register my newly installed system using the subscription-manager.
But when I try to use yum I get this:

yum repolist available
Loaded plugins: product-id, search-disabled-repos, subscription-manager
https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rt/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/solutions/69319

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rt/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.
repolist: 0


I've gone through the instructions from solution 69319 but nothing changes.
I've gone through multiple attempts with this sequence of commands:

subscription-manager unregister
subscription-manager register
subscription-manager refresh
subscription-manager attach --auto

Nothing changes.

I've tried to re-install a couple of times. Still the same.

I'm sure I'm missing something simple.
What is it?
Thanks for any help.
John

PS: In case it matters:

cat /etc/os-release
NAME="Red Hat Enterprise Linux Server"
VERSION="7.3 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="7.3"
PRETTY_NAME="Red Hat Enterprise Linux"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.3:GA:server"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.3
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.3"

johnddehart's picture

Responses

I am encountering the same issue, trying to run "yum upgrade" from a 7.2 server.

I have tried everything noted in solution 69319, as well. Seems to be an issue on RedHat's end.

https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rt/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden

I'm having the exact same issue. As a workaround to get me going, I disabled the repo with the following command:

subscription-manager repos --disable=rhel-7-server-rt-beta-rpms

Thanks. That helps a lot.

That workaround worked perfectly, thanks!

Thank you! Saved me!

As this is a temporary problem which only sometimes occurs - it might be better to choose one of these two options :
(instead of disable permanently by subscription-manager repos --disable=rhel-7-server-rt-beta-rpms)

Either disable the repository temporarily when running a yum command ->
sudo yum <command (for example update or install)> --disablerepo=rhel-7-server-rt-beta-rpms

Or you can configure the failing repository to be skipped if it's unavailable ->
sudo yum-config-manager --save --setopt=rhel-7-server-rt-beta-rpms.skip_if_unavailable=true

Exact issue for me and applied the same fix.

Great

Was this helpful?

We appreciate your feedback. Leave a comment if you would like to provide more detail.
It looks like we have some work to do. Leave a comment to let us know how we could improve.
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.