Dual Boot Issues with windows 10 & RHEL

Latest response

Hi All,

Warm Greetings to all,

My query is, I have dell laptop with windows 10 installed. As of now i have started learning RHEL 7 so tried to install Linux on the same laptop and thought I could make it dual boot.
But dont know where I made mistake please help me,

Step that I performed;
Step 1 : I made a 98 GiB space unallocated out of 500GiB Hard Drive for linux installation, then i insert the RHEL disc and started installation.
Step 2: I given 3GiB for Swap and rest given to "/". with Standard Partition & EXT4 file system.
Now the installation done and able to boot with Linux but dual boot was not there.
I tried to check some internet tricks but i didnt know how to put them in /grub2/grub.cfg.
Then i recovered my MBR using the windows installation disc. but now am not able to boot with RHEL.

I tried EASYBCD tool so that i can make it dual boot. some how it detected the linux partitions i made entry but it was not booting to linux, always showing the GRUB> window. where i can use only few commands.

Can any body please help me how do i make my Windows 10 64bit and RHEL 7.3 64 bit dual boot ?

Sorry for my bad English..

Please help me to get this done.

Responses

First things first : You should not use 3rd party tools like EasyBCD, they can cause a whole lotta trouble, so undo all actions you made with this tool and uninstall it. Second point : In case that your DELL notebook has an EFI based BIOS, GRUB has to be installed to the EFI partition and not to the MBR. Solution : Disable hibernation and Fast start up in Windows and then shutdown the PC completely. Now boot from the RHEL installation medium and reinstall GRUB. Afterwards boot into BIOS and select RHEL as the default system. After having done these steps, the GRUB boot loader should be visible and give you the option to boot either RHEL or Windows.

What about when my first operating system windows 10 is on a MBR partition ? Please help me with step by step instructions and authentic affiliated links. I am a novice willing to learn whatever it takes to get this done.

Hi Puneeth,

In a scenario with legacy (MBR) BIOS the GRUB boot loader overwrites the Windows loader.
When you boot your machine GRUB appears and lets you choose which system shall boot. :)

Regards,
Christian

Hi Christian, I have a similar problem while installing RHEL 7.3 in Dell XPS 9560 (64 bit) with 512 SSD with Windows 10 running. I have tried to install RHEL 7.3 via USB boot, while installing I got stuck at this location, INSTALLATION SECTION -> Device Selection -> Local Standard Disk shows "NOTHING" but the following error message "No disk detected. Please shutdown the computer, connect at least one disk, and restart to complete the installation". Please assist.

Hi Venkat,

This is most probably due to the fact that all partitions on the disk are formatted with ntfs. Download the GParted ISO file from the GParted website - create a bootable USB media from this .iso file and boot from that USB drive.

Create a new partition and format it with ext4, create another partition and format it with swap. In case there is no free space on the disk, shrink the Windows partition. I've made a presentation to make it a bit easier to understand :
How to prepare a GPT based disk for an installation of a Linux operating system with GParted

Once finished, boot from the RHEL installation media and select the option "I will configure partitioning" from the Anaconda installer. Choose the partitions you have created before : / (root) and swap. Choose the existing efi partition as boot loader location.

By the way, RHEL 7.4 was just released, so I recommend to install that instead of RHEL 7.3 ... I wish you good luck !

Cheers :)
Christian

Something is still wrong. I tried to create partition using GParted but it only shows the USB drive in the partition window. Am i missing anything ?

Hi Christian, I have disabled SECURE BOOT option and changed the boot option from UEFI to LEGACY mode which later listed the SSD in INSTALLATION DESTINATION page. I'm able to successfully install RHEL 7.4 but Windows 10 is gone.

Hi Venkat,

It seems that you've chosen the default option when you installed RHEL, which can mean that the whole disk was wiped ... in case you want to reinstall Windows, I'd suggest that you start over from scratch. First boot from the GParted USB media and create a new GPT partition table, which wipes everything again, then create the partitions that are needed for Windows and for the RHEL system.

Leave Secure Boot disabled (Windows nevertheless boots in secure mode) - but change the boot mode back to UEFI. Afterwards install Windows and then RHEL 7.4, but this time choose "manual configuring" in Anaconda installer and select the ext4 partition for RHEL you had created before.

Regards,
Christian

Its good to see more and more people from India getting interested in Linux. Keep it up. If you are trying RHEL in VM then try RHEL 8 it's awesome. I had dual boot, I completely moved out of Windows. I will recommend to use single boot instead (Only RHEL). And whenever you need Windows use KVM virtualisation (it works smoothly: use 32 bit in VM {it will consume less ram}). I assume you got 8 GB RAM in your machine.

After several days trying to install RHEL8, I failed to install, I could not create the USB boot correctly from ISO, try to create from windows 10 with almost all programs, in linux try to create with programs and from the command line but Nothing that can be created successfully, therefore the BIOS does not recognize the created USB, please how do I create the bootable USB correctly from either Windows 10 or Linux, please help, it is 5 days I try. My USB is 64 GB so I do not think it is space, not all files are copied to the usb boot and that does not recognize I believe the UEFI BIOS. Thank you!! Sorry for the English

Hi Team,

Can any one please help me in resolving my issue with red hat 7.2. I installed RedHatEnterpriseLinux 7.2 in my laptop by creating freespace in one of the drive. I inserted the red hat Linux disk and installed the OS. RedHat linux installed and it is running fine but it is not showing booting option for windows 10 os. I dont know how to resolve this issue, Please help me regrading this issue.

Thanks and Regards Shaik Nashruddin.

Shaik Nashruddin, it is better you spin out a new thread for this, because this thread might have been marked as resolved and you may not get proper help. You may have to define the issue clearly.. just saying ...

it is not showing booting option for windows 10 os

is not enough. Hence, please open a new thread and clearly write out the issue with all steps and screen images if you've to get help.

Hi Shaik,

Sadashiva is right, you definitely have to provide more information and because nearly every setup is different, a new thread would be a good idea. But to give you a first advice ... please check whether Windows is still installed at all. As I said above, many users accidentally 'wipe the whole disk' when attempting to install a new system. Secondly, execute sudo grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg if you have installed the RHEL system in EFI mode or sudo grub2-mkconfig -o /boot/grub2/grub.cfg when you have installed the system in legacy BIOS (mbr) mode.

Maybe that is already enough to let Windows appear in the GRUB boot menu. You also should check in BIOS if there is a boot option for Windows and if you can launch it from there - this is valid for UEFI installation only. Something else :
Why did you install RHEL 7.2 and not the latest stable edition 7.4 ? Upgrading later on might cause a lot of trouble ! :)

Regards,
Christian

Hi all, I just installed RHEL 7.4 on my lenovo thinkcenter desktop. I have Windows 10 installed before then. I created a partion of 40GB where i installed Linux. Now i cant boot to Windows any more. Could some please help me with a detailed step-by-step procedure to dual boot my system.

Thank you

Hi Nureni,

Execute sudo grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg and reboot. Now you should see a Windows entry in the GRUB boot menu - if you don't, boot into BIOS and check whether you can select to boot Windows from there. In case Windows is not listed, boot from the Windows installation medium and reinstall the Windows boot loader (select "Repair my computer" - follow the instructions). Maybe you have to reinstall GRUB afterwards (do this from the RHEL installation medium), because Windows tends to override the EFI partition. :)

Regards,
Christian

Hi all, I just installed RHEL 7.4 on my lenovo thinkcenter desktop. I have Windows 10 installed before then. I created a partion of 40GB where i installed Linux. Now i cant boot to Windows any more. Could some please help me with a detailed step-by-step procedure to dual boot my system.i also edit grub file but windows can't boot.That's so signature error so anyone help me ???????

Hi Jenish,

As you asked the same as Nureni - please try to solve the problem right the way I described in my response above.
By the way, I am wondering why you both chose to install RHEL 7.4 and not the latest stable edition RHEL 7.5 ? :)

Regards,
Christian

sorry for give you same wrong information i try it in RHEL 7.2

No problem Jenish, the solution I've provided to Nureni would be the same for you nevertheless ... good luck ! :)

Regards,
Christian

Hi christian,

I had windows 7 installed and working . i tried to install RHEL 7.0 installation started and failed after 5-10 mins that an error occurred hence i had to quit and after that i am unable to boot windows 7 even i tried to repair and reinstall using win 7 installation media but unable to detect my sata hardisk. Please help and suggest.

Obaid

Hi Obaid,

Did you select "Automatic Partitioning" ? If you didn't select "Manual Partitioning" the whole disk was used. That means that everything has been wiped and in this case you - unfortunately - have to reinstall Windows and RHEL.
Sorry for being the harbinger of bad news ... :)

Regards,
Christian

If this still helps someone: I also was unable to boot into the Windows partition after installing RHEL 7.5. Eventually found out that the Windows Bootloader was corrupt. You can check this by loading the UEFI boot menu and trying to load the "Windows boot manager" entry. Fixed the bootloader based on this article: http://woshub.com/how-to-repair-uefi-bootloader-in-windows-8/ (note to use correct locale in case Windows is not en-us). Then I managed to add it to grub using grub2-mkconfig,

Best Regards,

Amit

try this link

https://github.com/ravikantchauhan/windows-readhat_dual_boot

I have Windows 10 and just installed RHEL 8 for dual-boot. All went well except Windows is not on the boot list in grub. I've tried everything I could find. Very frustrated. So here's what I have. I sure hope someone can help.

fdisk -l

Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 28361431-BD10-4B38-A767-7599C1388201

Device          Start        End    Sectors  Size Type
/dev/sda1        2048     534527     532480  260M EFI System
/dev/sda2      534528     567295      32768   16M Microsoft reserved
/dev/sda3      567296 3853938687 3853371392  1.8T Microsoft basic data
/dev/sda4  3905140736 3907028991    1888256  922M Windows recovery environment
/dev/sda5  3853938688 3856035839    2097152    1G Linux filesystem
/dev/sda6  3856035840 3905140735   49104896 23.4G Linux LVM

Partition table entries are not in disk order.

Disk /dev/mapper/rhel-root: 21 GiB, 22515023872 bytes, 43974656 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk /dev/mapper/rhel-swap: 2.5 GiB, 2625634304 bytes, 5128192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes



blkid

/dev/sda1: SEC_TYPE="msdos" UUID="B0D4-C513" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="5d0572af-b4ef-458f-964a-15940c60e819"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="93cd40aa-57c6-4f87-adc4-56a283b189f4"
/dev/sda3: LABEL="CDRIVE" UUID="2C7A0DA07A0D6842" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="96426bf8-8ccc-4bfd-af54-3636b9d1c6a9"
/dev/sda4: UUID="14D8C4D6D8C4B6F0" TYPE="ntfs" PARTUUID="cf1ecfe8-f5da-4cda-bb18-ad30548fd00b"
/dev/sda5: UUID="f9250fd4-bef2-4d68-9210-22755bfb5b79" TYPE="xfs" PARTUUID="818ff5f5-7f78-48ca-9431-055b47dad784"
/dev/sda6: UUID="P5aJDw-685l-C3wP-Kwij-uKz9-aDin-Gz1YyO" TYPE="LVM2_member" PARTUUID="9f59446e-08ca-4e4a-9a55-65e745ad72e4"
/dev/mapper/rhel-root: UUID="7ec10dec-af11-4229-a48a-f167c35f032b" TYPE="xfs"
/dev/mapper/rhel-swap: UUID="96aea782-27da-4961-b4c5-055cf6883cf5" TYPE="swap"


With that information, I've tried several configurations and have had ZERO luck.

menuentry "Windows 10 " {
set root=(hd0,1)
search --no-floppy --fs-uuid --set=root 5d0572af-b4ef-458f-964a-15940c60e819
chainloader +1
}

Thanks in advance for any replies Jerry

Hi Jerry,

Please execute sudo grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg ... Reboot the system.
If it doesn't solve the problem - first reinstall the Windows Loader, and afterwards the GRUB boot loader.
Run the command again. If it also doesn't solve your problem, boot into BIOS and start Windows there. :)

Regards,
Christian

Hii I am doing a Dual boot of RHEL 8.0 on the Windows 10 Computer with a 1 TB Hard disk with unallocated space of 223 GB but after customized the Partition I am Facing an "Error a Storage Device Configuration" . Anyone Help with this to resolve this error.

Hi ! :)

In case you decided to set up a LVM configuration, you need more than one partition, you need one for /boot
and another one for LVM (root and swap volume as a minimum). The boot loader gets installed to the already
existing EFI partition, so choose this one ... the installer will complain until everything is configured correctly.

Regards,
Christian

Hii Christian,

Thank You for your great idea it works well and I also found another option as running in legacy mode detects the EFI partition automatically So the installation goes smoothly.

Great ! :) I'm glad you could get it done and that I was able to point you into the right direction.