Yum installing 32big GNU development tools on x64 system

Latest response

I have been using Red Hat with 64bit development tools since January this year, the project I am now working on requires 32bit GNU tools. I've checked:

    /usr/include/gnu

It contains:

-rw-r--r--. 1 root root 1270 Aug 11 06:56 libc-version.h
-rw-r--r--. 1 root root 4844 Aug 11 06:56 lib-names.h
-rw-r--r--. 1 root root  604 Aug 11 06:57 stubs-64.h
-rw-r--r--. 1 root root  384 Aug 11 06:56 stubs.h

I tried to install the 32bit tools:

sudo yum install glibc-devel.i686

But the result is:

Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package glibc-devel.i686 0:2.17-106.el7_2.8 will be installed
--> Processing Dependency: glibc = 2.17-106.el7_2.8 for package: glibc-devel-2.17-106.el7_2.8.i686
--> Processing Dependency: glibc-headers = 2.17-106.el7_2.8 for package: glibc-devel-2.17-106.el7_2.8.i686
--> Finished Dependency Resolution
Error: Package: glibc-devel-2.17-106.el7_2.8.i686 (rhel-7-workstation-rpms)
   Requires: glibc = 2.17-106.el7_2.8
   Installed: glibc-2.17-157.el7.i686 (@rhel-7-workstation-rpms)
       glibc = 2.17-157.el7
   Available: glibc-2.17-55.el7.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-55.el7
   Available: glibc-2.17-55.el7_0.1.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-55.el7_0.1
   Available: glibc-2.17-55.el7_0.3.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-55.el7_0.3
   Available: glibc-2.17-55.el7_0.5.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-55.el7_0.5
   Available: glibc-2.17-78.el7.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-78.el7
   Available: glibc-2.17-105.el7.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-105.el7
   Available: glibc-2.17-106.el7_2.1.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-106.el7_2.1
   Available: glibc-2.17-106.el7_2.4.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-106.el7_2.4
   Available: glibc-2.17-106.el7_2.6.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-106.el7_2.6
   Available: glibc-2.17-106.el7_2.8.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-106.el7_2.8
Error: Package: glibc-devel-2.17-106.el7_2.8.i686 (rhel-7-workstation-rpms)
   Requires: glibc-headers = 2.17-106.el7_2.8
   Installed: glibc-headers-2.17-157.el7.x86_64 (@rhel-7-workstation-rpms)
       glibc-headers = 2.17-157.el7
   Available: glibc-headers-2.17-55.el7.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-55.el7
   Available: glibc-headers-2.17-55.el7_0.1.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-55.el7_0.1
   Available: glibc-headers-2.17-55.el7_0.3.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-55.el7_0.3
   Available: glibc-headers-2.17-55.el7_0.5.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-55.el7_0.5
   Available: glibc-headers-2.17-78.el7.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-78.el7
   Available: glibc-headers-2.17-105.el7.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-105.el7
   Available: glibc-headers-2.17-106.el7_2.1.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-106.el7_2.1
   Available: glibc-headers-2.17-106.el7_2.4.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-106.el7_2.4
   Available: glibc-headers-2.17-106.el7_2.6.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-106.el7_2.6
   Available: glibc-headers-2.17-106.el7_2.8.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-106.el7_2.8
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************
Error: Package: glibc-devel-2.17-106.el7_2.8.i686 (rhel-7-workstation-rpms)
   Requires: glibc = 2.17-106.el7_2.8
   Installed: glibc-2.17-157.el7.i686 (@rhel-7-workstation-rpms)
       glibc = 2.17-157.el7
   Available: glibc-2.17-55.el7.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-55.el7
   Available: glibc-2.17-55.el7_0.1.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-55.el7_0.1
   Available: glibc-2.17-55.el7_0.3.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-55.el7_0.3
   Available: glibc-2.17-55.el7_0.5.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-55.el7_0.5
   Available: glibc-2.17-78.el7.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-78.el7
   Available: glibc-2.17-105.el7.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-105.el7
   Available: glibc-2.17-106.el7_2.1.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-106.el7_2.1
   Available: glibc-2.17-106.el7_2.4.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-106.el7_2.4
   Available: glibc-2.17-106.el7_2.6.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-106.el7_2.6
   Available: glibc-2.17-106.el7_2.8.i686 (rhel-7-workstation-rpms)
       glibc = 2.17-106.el7_2.8
Error: Package: glibc-devel-2.17-106.el7_2.8.i686 (rhel-7-workstation-rpms)
   Requires: glibc-headers = 2.17-106.el7_2.8
   Installed: glibc-headers-2.17-157.el7.x86_64 (@rhel-7-workstation-rpms)
       glibc-headers = 2.17-157.el7
   Available: glibc-headers-2.17-55.el7.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-55.el7
   Available: glibc-headers-2.17-55.el7_0.1.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-55.el7_0.1
   Available: glibc-headers-2.17-55.el7_0.3.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-55.el7_0.3
   Available: glibc-headers-2.17-55.el7_0.5.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-55.el7_0.5
   Available: glibc-headers-2.17-78.el7.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-78.el7
   Available: glibc-headers-2.17-105.el7.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-105.el7
   Available: glibc-headers-2.17-106.el7_2.1.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-106.el7_2.1
   Available: glibc-headers-2.17-106.el7_2.4.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-106.el7_2.4
   Available: glibc-headers-2.17-106.el7_2.6.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-106.el7_2.6
   Available: glibc-headers-2.17-106.el7_2.8.x86_64 (rhel-7-workstation-rpms)
       glibc-headers = 2.17-106.el7_2.8
 You could try using --skip-broken to work around the problem
** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.4.0-12.el7.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-12.el7.x86_64
ipa-client-common-4.4.0-12.el7.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-12.el7.noarch
ipa-common-4.4.0-12.el7.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-12.el7.noarch
ipa-python-compat-4.4.0-12.el7.noarch has installed conflicts freeipa-        python-compat: ipa-python-compat-4.4.0-12.el7.noarch

The actual version of redhat is:

    Red Hat Enterprise Linux Workstation release 7.3 (Maipo)

How can I resolve this issue?

Responses

Error: Package: glibc-devel-2.17-106.el7_2.8.i686 (rhel-7-workstation-rpms)
   Requires: glibc = 2.17-106.el7_2.8
   Installed: glibc-2.17-157.el7.i686 (@rhel-7-workstation-rpms)
       glibc = 2.17-157.el7

It looks like you are trying to install glibc-devel-2.17-106 (32-bit), which requires the same version glibc-devel 64-bit to be installed, but you have glibc-devel-2.17-157 (64-bit) which is a newer version installed.

Do you have glibc-devel-2.17-157.el7.i686 available if you run yum list available glibc-devel?