Mp4 in RHEL 7, why won't it play

Latest response

How do I get RHEL 7 to read mp4 files?

The video player is unable and neither can presentations in office libre. Google Chrome can. I have tried the EPEL, rpmfusion , and rpmforge repositories, but am going in circles and worry about jeopardizing integrity of system.

Would appreciate hearing what others have tried. Any guidance would be appreciated.

Thank you!

Dan

Attachments

Responses

Please see https://access.redhat.com/discussions/1437813.

Link is dead........

the period may have gotten in the way of the url. Try this link https://access.redhat.com/discussions/1437813 which should work.

I just installed Fluendo Oneplay and it works perfectly and it was very easy to install. I don't mind having to pay if there is no reliable free solution. I tried the 3rd party repositories and all had missing dependencies or were altogether off-line.

Download VideoLAN its free and plays just about anything.

VideoLAN (vlc) won't work. It will just play the audio formats.

yum install ffmpeg-dev

yum install mplayer

After this one, do as root next steps; I'm gonna post one by one.

git clone https://github.com/mpv-player/ffmpeg-mpv.git

cd ffmpeg-mpv

./configure

make && make install

if having errors, and with rhel7 you should recieve it, do this.

yum install nasm yasm

now again run

./configure && make && make install

Sharing my personal experience, I was able to listen the first song after 48 hours, still I'm getting errors playing mp4. Don't worry, I'll post the solution asap.

run the below command that should work.

yum install gstreamer1-pluging*

RHSA-2017:0021 - Security Advisory # Please read & try this

thank you, it worked

found vlc few years ago, installed it on RHEL 7, and it works ever since.