Unable to enable em1 interface on a Dell R720xd server running rhel 7

Latest response

I'm having trouble enabling a em1 (1 Gbps) interface on RHEL 7. When trying to do so, I lose the connectivity to the machine and have to restart or access it via the console

ifdown em1

ifup em1

===> lose connectivity and need to reboot the server (console doesn't show the GUI/desktop) :(

I've tried to delete the configuration file from /etc/sysconfig/network-scripts/ifcfg-em1 and recreate it. No progress.
```

ifconfig em1

em1: flags=4098<BROADCAST,MULTICAST> mtu 1500
ether f8:bc:12:4d:f3:00 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 35

cat /etc/sysconfig/network-scripts/ifcfg-em1

TYPE=Ethernet
BOOTPROTO=static
DEVICE=em1
ONBOOT=yes
IPADDR=172.39.0.31
NETMASK=255.255.255.0

```
Notes:

  1. The Link status on iDRAC shows up as UP but the ethtool reports that Link status is 'no' (meaning the link is down)
  2. NetworkManager is stopped and disabled.
  3. Few details about the the interface configuration:
    ```

ethtool -a em1

Pause parameters for em1:
Autonegotiate: on
RX: on
TX: on

ethtool -i em1

driver: tg3
version: 3.137
firmware-version: FFV7.8.16 bc 5720-v1.32
bus-info: 0000:01:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no
Additionally, here's an output from the ip a command
2: em1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
link/ether f8:bc:12:4d:f3:00 brd ff:ff:ff:ff:ff:ff
```

Can someone help please?

Responses

Hello

"NO-CARRIER" suggests no connection, which could be a cable problem or no network switch at the far end, hence the link is reported as "Down".

Are there lights on the RJ45 socket? Is the cable known to be OK?
Is it connected to a network switch?
Are you using SSH to connect over this em1 interface?

Are there lights on the RJ45 socket? Is the cable known to be OK?
I have had guys at the datacenter change the Network Cables and connect to another port but still the same issue on em2 as well

Is it connected to a network switch?
yes -it is

Are you using SSH to connect over this em1 interface?
NO - I'm using another interface - a 10 Gbps NIC

This article suggests booting with the previous kernel if it was working before, otherwise it suggestsusing modprobe to manually load the driver Basic Network troubleshooting

This article is also worth reading Why does ethtool show 'no link' for ethernet interface even though cable is physically connected?

If you still have no luck please post log messages related to tg3 driver.

Problems related to the version of the Network Interface card driver or firmware are a possibility, and therefore it is worth checking for updates from the vendor.

The issue has been fixed by enabling the port at the network switch where the cable was connected. The port had been disabled due to an unknown issue (status: err-disabled).

I was then able to enable the interface and connectivity was restored.

Thanks a lot for your help...!

Thank you for letting us know the result.