Using VLANS on Teamed connection

Latest response

Hi All,

Having a few problems this, used to use bonding fine in RH6, but in RH7 I wanted to go over to teaming for the extra features.

I have 4 interfaces teamed into team0. They all have 2 vlans passed down them.

I have created ifcfg-team.XXX and ifcfg-team.xxx for the VLANs as before.

When bringing them up I get the following error : /usr/sbin/ifup: line 102: is_available_wait: command not found.

I also had this problem when I just imported my normal bond vlan configurations into a RHEL 7 machine.

My ifcfg-team0.XXX file is as follows:
DEVICE=team0.XXX
BOOTPROTO=none
ONBOOT=yes
IPADDR=XXX.XXX.XXX.XXX
NETMASK=XXX.XXX.XXX.XXX
DNS1=XXX.XXX.XXX.XXX
DNS2=XXX.XXX.XXX.XXX
DNS3=XXX.XXX.XXX.XXX
VLAN=yes

Anyone got any ideas on this?

I have X'd out all IP addresses and VLANS for security reasons.

Thanks.

Responses

Hello

I will try to reproduce what you have there.

Useful info Understanding the Default Behavior of Master and Slave Interfaces

Edit: I have been told using the ONPARENT directive is not required in RHEL7. This looks like a bug, I will try to reproduce it and then file a bug.

Seems to work OK.

I used PREFIX just because its easier to type. It is preferred for new configs.

=======On a RHEL7 Workstation VM:=========

root@localhost ~]# vi /etc/sysconfig/network-scripts/ifcfg-eth0
TYPE=Ethernet
DEVICE=eth0
HWADDR=52:54:00:38:a6:4c
BOOTPROTO=none
DEVICETYPE=TeamPort
ONBOOT=yes
TEAM_MASTER=team0
TEAM_PORT_CONFIG='{"prio": 100}'

root@localhost ~]# vi /etc/sysconfig/network-scripts/ifcfg-team0
DEVICE=team0
DEVICETYPE=Team
ONBOOT=yes
BOOTPROTO=none
IPADDR=192.168.122.11
PREFIX=24
TEAM_CONFIG='{"runner": {"name": "activebackup"}, "link_watch": {"name": "ethtool"}}'

[root@localhost ~]# ifup team0

[root@localhost ~]# ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
link/ether 52:54:00:38:a6:4c brd ff:ff:ff:ff:ff:ff
3: ens9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
link/ether 52:54:00:e9:ce:d2 brd ff:ff:ff:ff:ff:ff
5: team0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT
link/ether a2:70:1a:78:67:53 brd ff:ff:ff:ff:ff:ff

[root@localhost ~]# service network restart
Restarting network (via systemctl): [ OK ]
[root@localhost ~]# ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master team0 state UP mode DEFAULT qlen 1000
link/ether 52:54:00:38:a6:4c brd ff:ff:ff:ff:ff:ff
3: ens9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
link/ether 52:54:00:e9:ce:d2 brd ff:ff:ff:ff:ff:ff
6: team0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT
link/ether 52:54:00:38:a6:4c brd ff:ff:ff:ff:ff:ff
[root@localhost ~]# vi /etc/sysconfig/network-scripts/ifcfg-team0.22
DEVICE=team0.22
BOOTPROTO=none
ONBOOT=yes
IPADDR=192.168.50.50
PREFIX=24
VLAN=yes

[root@localhost ~]# ifup team0.22
[root@localhost ~]# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master team0 state UP mode DEFAULT qlen 1000
link/ether 52:54:00:38:a6:4c brd ff:ff:ff:ff:ff:ff
3: ens9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
link/ether 52:54:00:e9:ce:d2 brd ff:ff:ff:ff:ff:ff
6: team0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT
link/ether 52:54:00:38:a6:4c brd ff:ff:ff:ff:ff:ff
7: team0.22@team0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT
link/ether 52:54:00:38:a6:4c brd ff:ff:ff:ff:ff:ff
[root@localhost ~]#

[root@localhost ~]# ip route
192.168.50.0/24 dev team0.22 proto kernel scope link src 192.168.50.50
192.168.122.0/24 dev team0 proto kernel scope link src 192.168.122.11
[root@localhost ~]#

[root@localhost ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master team0 state UP qlen 1000
link/ether 52:54:00:38:a6:4c brd ff:ff:ff:ff:ff:ff
3: ens9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether 52:54:00:e9:ce:d2 brd ff:ff:ff:ff:ff:ff
6: team0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
link/ether 52:54:00:38:a6:4c brd ff:ff:ff:ff:ff:ff
inet 192.168.122.11/24 brd 192.168.122.255 scope global team0
valid_lft forever preferred_lft forever
inet6 fe80::5054:ff:fe38:a64c/64 scope link
valid_lft forever preferred_lft forever
7: team0.22@team0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
link/ether 52:54:00:38:a6:4c brd ff:ff:ff:ff:ff:ff
inet 192.168.50.50/24 brd 192.168.50.255 scope global team0.22
valid_lft forever preferred_lft forever
inet6 fe80::5054:ff:fe38:a64c/64 scope link
valid_lft forever preferred_lft forever
[root@localhost ~]# ping -c4 192.168.50.52
PING 192.168.50.52 (192.168.50.52) 56(84) bytes of data.
64 bytes from 192.168.50.52: icmp_seq=1 ttl=64 time=14.7 ms
64 bytes from 192.168.50.52: icmp_seq=2 ttl=64 time=0.481 ms
64 bytes from 192.168.50.52: icmp_seq=3 ttl=64 time=0.416 ms
64 bytes from 192.168.50.52: icmp_seq=4 ttl=64 time=37.0 ms

--- 192.168.50.52 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 0.416/13.173/37.079/14.980 ms
[root@localhost ~]#

=======On a RHEL7 server VM========

[root@localhost ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master team0 state UP qlen 1000
link/ether 52:54:00:34:29:36 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether 52:54:00:63:5b:43 brd ff:ff:ff:ff:ff:ff
4: team0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
link/ether 52:54:00:34:29:36 brd ff:ff:ff:ff:ff:ff
inet 192.168.122.12/24 brd 192.168.122.255 scope global team0
valid_lft forever preferred_lft forever
inet6 fe80::5054:ff:fe34:2936/64 scope link
valid_lft forever preferred_lft forever
5: team0.22@team0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
link/ether a2:29:ac:f2:ac:01 brd ff:ff:ff:ff:ff:ff
inet 192.168.50.52/24 brd 192.168.50.255 scope global team0.22
valid_lft forever preferred_lft forever
inet6 fe80::a029:acff:fef2:ac01/64 scope link
valid_lft forever preferred_lft forever
[root@localhost ~]#

[root@localhost ~]# ip route
192.168.50.0/24 dev team0.22 proto kernel scope link src 192.168.50.52
192.168.122.0/24 dev team0 proto kernel scope link src 192.168.122.12
[root@localhost ~]#

[root@localhost ~]# ping -c4 192.168.50.50
PING 192.168.50.50 (192.168.50.50) 56(84) bytes of data.
64 bytes from 192.168.50.50: icmp_seq=1 ttl=64 time=17.4 ms
64 bytes from 192.168.50.50: icmp_seq=2 ttl=64 time=32.8 ms
64 bytes from 192.168.50.50: icmp_seq=3 ttl=64 time=0.378 ms
64 bytes from 192.168.50.50: icmp_seq=4 ttl=64 time=0.561 ms

--- 192.168.50.50 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3002ms
rtt min/avg/max/mdev = 0.378/12.806/32.858/13.489 ms
[root@localhost ~]#

========================================================

This was based on:
Creating a Network Team Using ifcfg Files
and:
Setting Up 802.1Q VLAN Tagging Using ifcfg Files

Thank you