CVE-2018-16842

Impact:
Low
Public Date:
2018-10-31
CWE:
CWE-125
Bugzilla:
1644124: CVE-2018-16842 curl: Heap-based buffer over-read in the curl tool warning formatting

The MITRE CVE dictionary describes this issue as:

Curl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer over-read in the tool_msgs.c:voutf() function that may result in information exposure and denial of service.

Find out more about CVE-2018-16842 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

NOTE: The following CVSS v3 metrics and score provided are preliminary and subject to review.

CVSS3 Base Score 3.6
CVSS3 Base Metrics CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:L
Attack Vector Local
Attack Complexity High
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Low
Integrity Impact None
Availability Impact Low

Affected Packages State

Platform Package State
Red Hat Software Collections for Red Hat Enterprise Linux httpd24-curl Affected
Red Hat JBoss Web Server 5 curl Under investigation
Red Hat JBoss Core Services 1 curl Under investigation
Red Hat Enterprise Linux 7 curl Affected
Red Hat Enterprise Linux 6 curl Will not fix
Red Hat Enterprise Linux 5 curl Will not fix
.NET Core 2.0 on Red Hat Enterprise Linux rh-dotnet21-curl Affected
.NET Core 1.0 on Red Hat Enterprise Linux rh-dotnetcore10-curl Affected
.NET Core 1.0 on Red Hat Enterprise Linux rh-dotnetcore11-curl Affected

Acknowledgements

Red Hat would like to thank the Curl project for reporting this issue. Upstream acknowledges Brian Carpenter (Geeknik Labs) as the original reporter.

External References

Last Modified

CVE description copyright © 2017, The MITRE Corporation