Can't get repos working

Latest response

Hello everybody.
I'm having some issues with yum. When I run "yum repolist" I get this:

[root@SRVRG3ORAPP01 ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager
Updating certificate-based repositories.
Este sistema no está registrado con RHN.
El soporte de RHN Satellite o RHN Classic será desactivado.
file:///media/Server/repodata/repomd.xml: [Errno 14] Could not open/read file:///media/Server/repodata/repomd.xml
Trying other mirror.
repo id                                                                           repo name                                                                                                 status
dvd                                                                               Red Hat Enterprise Linux Installation DVD                                                                 0
rhel-6-server-rpms                                                                Red Hat Enterprise Linux 6 Server (RPMs)                                                                  0
repolist: 0

I have already registered and subscribed box to my account, and I've checked in portal and UUID is correct.
Can anyone help me with this issue?

Thanks!

Responses

Looks like you've got a repo defined in /etc/yum.repos.d that's expecting to find software on a mounted DVD. You've got a couple choices:
* Nuke the repo config out of /etc/yum.repos.d
* Set the "enabled" parameter's value to "0"
* (re) Mount the DVD that has the repomd.xml file on it.

I'd probably take the second option. That way, any time you want to do something from DVD, all you have to do to use it is pass an --enablerepo= option to yum.

Thanks Tom! I disabled the DVD repo and now is working.

Thanks again!