I'm can't add hypervisor to rhevm3.3

Latest response

Responses

Krisada, can you please provide some additional details to what is happening. There is a log at the bottom of the web portal that should indicate what is wrong.

Some possible issues:
ssh is not enabled between RHEV manager and Hypervisor
Hypervisor does not have correct channels added
RHEV manager is not able to contact Hypervisor (network/firewall issues)
sudoers does not allow 'vdsm' user to execute commands

Please review:
https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.0/pdf/Evaluation_Guide/Red_Hat_Enterprise_Virtualization-3.0-Evaluation_Guide-en-US.pdf

Hi James Radtke

Error Events web on portal

After approve install host

"Host xxxx installation failed. SSH session timout host ‘root@192.168.xx.xx"
"Failed to install host xxx processing stopped due to timeout"

Thank you very much.

What is there in the logs at /var/log/ovirt-engine/host-deploy on RHEV-M?

Hi Puthen,
Deati this below.
[root@rhevm host-deploy]# pwd
/var/log/ovirt-engine/host-deploy
[root@rhevm host-deploy]# ls -l
total 0
-rw-r--r--. 1 ovirt ovirt 0 Jan 29 11:13 ovirt-20140129111344-192.168.1.124-6ee1589b.log
-rw-r--r--. 1 ovirt ovirt 0 Jan 29 12:17 ovirt-20140129121711-192.168.1.124-22960c06.log
-rw-r--r--. 1 ovirt ovirt 0 Jan 29 13:42 ovirt-20140129134233-192.168.1.124-41de8c91.log
[root@rhevm host-deploy]#

Thank you.

What error you see inside ovirt-20140129134233-192.168.1.124-41de8c91.log?

not have detail in log file.

Can you confirm that you can ssh from the RHEV-M server to the hypervisor server as root (or the credentials you are using)?

Is there Hypervisor you're attempting to add a RHEV-H server or RHEL?

Now,i can fix this problem. Thank you. :-)

Are you able to let us know what you did to the fix the problem in case others find this thread looking for a solution?

  • shutdown the KVM guest and removed the whole networking interfaces from the KVM host.
  • Then configured the network in the following manner:

    eth0______ br0
    |
    eth1

    We have created the bridge(br0) on the eth0 interface and then, reinstalled the rhev-H and then added it successfully to the rhev-M and then configured the ISO domain.