RHEL 9.0 ProxMox install = kernel panic

Latest response

I am attempting to install RHEL 9.0 GA in Proxmox (v7.1), but I get a kernel panic on boot during the install. Same issue with 9.0 Beta a couple of weeks ago.

I can't cut/paste from the ProxMox console, so see attached image. The most I can tell is that the root filesystem can't be mounted.

I've had no problems installing RHEL 8.6 Beta or GA on this system.

Thoughts?

Responses

(I don't know why my uploaded image only shows when I try to edit that post?)

I tried again with the minimal install "boot" ISO. Same problem. Last line of panic message: "Attempted to kill init!"

https://imgur.com/a/KLCiWkh

I got this working by setting the ProxMox VM cpu type to 'host'.

Thanks for this info.

Thanks David, worked for me too.

Killer info, thanks!

Thanks this worked for me as well.

Perfect! this worked too me

The CPU features required by RHEL 8 and RHEL 9 are different. I saw kernel crashes with Packer/Qemu and filed a bug (https://bugzilla.redhat.com/show_bug.cgi?id=2094260), there RH Engineering pointed this RHBZ for background information:

https://bugzilla.redhat.com/show_bug.cgi?id=2060839

As you've noticed and as mentioned in the Packer/Qemu RHBZ, using 'host' as vCPU type will avoid the issue. Ideally tools would use supported libvirt instead of unsupported qemu-kvm at least over the long-term.

Thank you! It's worked too me!!!