Redhat Enterprise Virtulization 3.1 Problem with VM Network (nic) Interface

Latest response

Respected Sir/Madam

We have the following configuration as below

1 ) Redhat Enterprise Virtulization Manager 3.1.4

2) Redhat Enterprise Virtulization Hypervisor 6.3

Yesterday i have faced the probelm regarding the network on one of the VM running on my Hypervisor

we have 2 VM on same RHEV Hypervisor (6.3)

Name of the VM

1) njbrok

2) njtran

Both are running in production environment

and we cannot bare downtime on connectivity loss  for both of the vm

The probelm is njtran VM's getting packet loss to it virtionet interface (nic) so the remote database server are getting problem with the connectivity to the njtran VM

And the njbrok vm which is running on the same Hypervisor does not have any connectivity or packet loss issue

So after much effort and after spending lot of time

i have solved the problem by making the VM njtran  poweroff  and remove the nic interface and re-added the interface agian and the problem got solved

But still i am not getting why this problem arise

and we cannot bare again if the same problem arise in the future

and if it arise how to solved it without making the production server down

Please respond as soon as possible

 

 

 

 

 

 

 

 

Responses

Far fetched, but: Do you have a test/development rhev setup? If you have multiple rhev environment, be aware that the mac-adress-pool by default is the same in all environments. And if the same mac-address get assigned to multiple vm's you might experience something like you describe. I'm talking from experience here....

/Brian

 

Good recommendation Brian.  I had not considered that the MAC Address pool would be similar.  I suppose even if the algorithm to create a new pool used the "base" of the system's actual MAC address, there would still be duplication.

Pratik - In addition, if you have a smart network group, they should be able to deduce whether a mac address is registered with multiple physical ports (I believe the CAM tables also associate the MAC address to an IP address - so that should be another place to look).