NTFS not being recognized

Latest response

When I try to mount my Seagate FreeAgent USB Drive, I get:

Error mounting: mount: unknown filesystem type 'ntfs'

When I try to create/mount a ntfs partition on my sdb drive to be later used as a Samba share, I get:

Error creating file system: Cannot run mkfs: cannot spawn 'mkntfs -f -L "MyFiles" /dev/sdb2': Failed to execute child process "mkntfs" (No such file or directory)

I realize that I need the drivers so my system recognizes nfts files. My system is telling me I may already have them when I try to install fuse-ntfs-3g:

Package fuse-2.8.304.e16.x86_64 already installed and latest version.

Are there any other prerequisites? Please advise when you can. Thanks, Dave

Responses

We do not ship NTFS support by default, or provide libaries which enable this support.

You may choose to enable NTFS with unsupported third-party libraries, EPEL package some.

 How to enable NTFS support in Red Hat Enterprise Linux
 https://access.redhat.com/knowledge/solutions/23993

Thank you very much. I was able to enable NTFS support.

Dave

This is what I did: 1. Ensure the following 2 repos are enabled: Rhel-7-server-extras-rpms & Rhel-7-server-optional-rpms 2. Open web browser on RHEL7 box then visit: fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages, then click on the link: The newest version of ‘epel-release’ for EL7, then Install downloaded RPM, then Open terminal: yum install ntfs-3g, then 'df –h' (verify NTFS filesystem is mounted) if not, mount it: mount /dev/sd* /directory. If you get an error you might have to spell out mount ntfs-3g /mountpoint /directory 3. Copy file to NTFS directory

Great!!!! you saved my day! I tried so many tips to get this ntfs3g package for days!! Thanks a lot!!!

Thanks, this worked perfectly :)

Solved my issue also - thanks.

Usb not connected in Red-hat linux operating...

Enamul Haque,

I see your message in your last post contains the following words:

Usb not connected in Red-hat linux operating...

I recognize English may not be your primary language, however, this is not enough for us to go on to help you.

I'm going to take some wild guesses here. Maybe you are attempting to use a USB drive that was formatted with NTFS. If that is what is going on for you, I recommend you attempt to use the solution posted by Jamie Bainbridge above.

Otherwise, we will need more details.

Kind regards,
RJ

how to uninstall ntfs-3g

Error parsing config: Error parsing "baseurl = 'ftp//:192.168.43.120/pub/IT'": URL must be http, ftp, file or https not
What solution of this error

updated post is below

I am getting the following error when plugging into a RHEL 7 machine. Not sure if we are allowed to install ntfs-3g because it is not from a trusted source. Need an alternate solution that will be approved on government devices. I am plugging in an Apricorn Aegis Padlock 3.0 to a RHEL 7 machine.

"filesystem type ntfs not configured in kernel"

Hi Luis Mendez, and welcome

I'm not certain if you really do or do not need the ntfs drivers. I'd recommend validating what filesystem was used to create the partitions for the hard drive you are using.

UPDATED 8/3/2021

If you wish to make a Red Hat Linux system use ntfs, use "EPEL" which stands for "Extra Packages for Enterprise Linux", which is under the Fedora Project (overseen by Red Hat).

To determine if you are allowed to use it or not, coordinate with whoever in your company oversees security matters and explain to them the EPEL project which is part of the Fedora Project, which is overseen by Red Hat itself. Please see the link in the above paragraph to understand EPEL.

This discussion was started in 2013, and things have changed since then, and the packages needed for actual NTFS are in EPEL and named (as I type this today) something like this. RHEL/CENTOS 7

ntfs-3g-CURRENT_VERSION_AT_LINK_ABOVE.rpm                                 
ntfs-3g-devel-CURRENT_VERSION_AT_LINK_ABOVE.rpm                          
ntfsprogs-CURRENT_VERSION_AT_LINK_ABOVE.rpm      

And for those who require RHEL/CentOS 8 rpm packages, something like this:

ntfs-3g-CURRENT_VERSION_AT_LINK_ABOVE.el8.x86_64.rpm    
ntfs-3g-devel-CURRENT_VERSION_AT_LINK_ABOVE.el8.x86_64.rpm  
ntfs-3g-system-compression-CURRENT_VERSION_AT_LINK_ABOVE.el8.x86_64.rpm  
ntfsprogs-CURRENT_VERSION_AT_LINK_ABOVE.el8.x86_64.rpm

Of course, verify you are really in need of NTFS by examining the partition using traditional methods in Linux.

Regards,
RJ

So for RHEL 7, I need to use all 3 rmps? and for RHEL 8, I need to use all 4 rmps? Letting you know also, the external drive is set to NFTS by default but I have 2 other options. exFAT and REFS. The PC that I'm on right now is set to xfs. Any of those two options compatible with xfs? I do believe that NTFS is not something that is set on our Linux environment.

Hi Luis Mendez,

Since you asked - what I've posted for the number of RPMS and the other info is correct, and it's what we do for those very very very few systems that require this. I've not explored exFAT and REFS on Linux.

XFS is of course the default file system for RHEL 7 and higher. XFS was on RHEL 6, but it had to be purchased separately. And your last statement, NTFS is not part of anyone's Linux environment by default unless someone has a need that is strong enough to justify it (which can be done, see my previous post). See my previous post on the nature of Red Hat's EPEL under their Fedora Project if you wish to justify it to those who govern your security policies because you can make your case with them if you so wish, this is your choice to pursue, or not.

There is a possibility under /etc/modprobe.d/* files you may have to comment out usb-storage blacklist directives.

Kind Regards,
RJ

Hello RJ,

Thank you for all the information. With the instructions provided, I did manage to get a RHEL 8 box working with the external drive still set to NTFS. I will try it on a RHEL 7 box next. Thank you again.

Hi there Luis,

I've added NTFS rpms (where justified) to both RHEL 8 and RHEL 7 and CentOS 7 as well using the above rpms for the absolute not-majority of systems (very very very very small amount of systems that require it).

Regards,
RJ