Solaris on rhev

Latest response


I wonder if some of you have made a RHEV Solaris installation and because they've run the network under this system.

Thank you very much for your help


I know opensolaris is capable of running within KVM, however whether there are virtio_blk and virtio_net drivers I can't say. With the basic e1000 and ide emulation, solaris will work, but it probably will not fly.


google comes up with several virtio porting projects for Solaris, you might want to try them.



And of course, Solaris is not supported as a guest OS, got to keep that in mind

Well, the thing is that I was able to run it on pure KVM before without a glitch (I had to upgrade libvirt only) and now I've installed on top of RHEV but I'm having issues with the network.


The Solaris works with IDE and with e1000 drivers or the rtl one.  However there's no network connectivity between the solaris vm and the rest of the world.


I made an experiment, I modified the ARP table of the VM and inserted the IP and MAC of an external machine, on the external machine I did the same.  The results were that a tcpdump running at the hypervisor level printed ICMP echo requests and replies, however there was no ping response from the external machine neither the solaris VM.


It seems like an iptables/routing/bridge issue but I was looking for some insights or help on this, as I know that solaris is not a guest supported.



Shouldn't happen, since the bridge simply throws traffic at the VM, no strings attached. So there are two suspects here - the VM itself, or the e1000 driver on solaris.


I would do the following here:

1. boot that VM up with a linux liveCD in order to see that the platform is operational and the issue is in the guest OS. If it works, it will prove for certain that there is a problem inside Solaris specifically, because the rest of the VM using a different OS just works.

2. sniff the bridge to see what happens to the traffic when it doesn't reach a solaris VM.


Again, totally unsupported, but if the e1000 driver in solaris is not compatible, you might have a chance by opening a BZ with Oracle or the OpenSolaris/OpenIndiana community


Hi Dan, thanks for you suggestions.   We've managed to get Solaris10U5 working on top of RHEV.


It seems that SunOS kernel introduced some change on the netcard drivers and this change doesn't work quite well with the VDSM/LIBVIRT/QEMU-KVM combination in RHEV.


This is the bug against QEMU-KVM (with a possible solution on the QEMU side)


However on our tests on top of pure QEMU-KVM (RHEL6.1) without RHEV, the Solaris worked without issues so it seems something can be done from our side too.


I tried to find a redhat bug report on this but wasn't able to find it.


best regards

Hmm, well, I would suggest you open a support case, but since solaris is not supported yet, it wouldn't help you much.


BTW, have you tried the virtio stack for solaris? It's up on github, and just might work

Gonna test it



Hi Andres,

Have you tried it yet? We have the same issues as you with solaris 10 and e1000.

Hello Pär !


We' ve got scheduled a Solaris 10 test using RHEV 3.1 at some time in the future. 


However at this moment Solaris10U5 is the only Solaris version that worked for us without issues on top of RHEV.


I'm not sure if there's been a new Solaris release since then but you're welcome to test and report back!


best regards,


PS: Abut the git repo, we did try to test it but we were unsuccessfull. We had compilation issues.