rdp not working vs a win 7 virtual desktop

Latest response

Client is Win XP SP3 and its browser is updated IE 8.

Connecting to a Win 7 32bit virtual desktop.

Spice is ok, but rdp not.

First time asked to install an activex plugin for rdp

But then following instructions double click doesn't raise any rdp window...

Guest has tools installed

How to debug this?

 

Steps:

To configure RDP connection protocol options
  1. Select a running virtual machine. Click Edit as illustrated in Figure 3.1, “Select connection protocol”.
  2. The Console Options dialog displays as illustrated in Figure 3.2, “Configure Console Options”.
  3. Select Remote Desktop. The RDP Options display.
    • Use Local Drives: Tick this checkbox to use local CD or DVD drives on the virtual guest.
  4. Click OK. You are returned to the User Portal. Double click on your selected virtual machine to connect to it.

 

Responses

Are you able to connect to the VM via RDP manually? run mstsc /v <IP_of_VM> in the client machine

No,

I get impossible to connect.

And the same error if I use the admin portal, select the VM line and select the "RDP" option at the display icon menu....

 

BTW: I thought the rdp connection as tunneled through the host (aka hypervisor)... while instead is it a direct rdp connection from client to guest?

 

  

So I got this:

http://technet.microsoft.com/en-us/magazine/ff404238.aspx

 

and configured win 7 to allow access.

I presume I have to preconfigure this way the win 7 vm candidate to become a template for a pool if I want then to allow rdp access, correct? Is this customization retained during sysprep?

 

And I have to put my users inside remote access list too..

I admit I'm not a Window systema administrator, but I found this at the moment:

 

1) mstsc /v <IP_of_VM> didn't work

2) granted remote access as from

http://technet.microsoft.com/en-us/magazine/ff404238.aspx

3) verified that now from IE admin portal I can open an rdp console

3) put my group of windows AD users that needs to access the pool into remote desktop users of the AD

4) mstsc /v <IP_of_VM> didn't work using one of those users

5) I found that actually there is also a local "remote desktop users" for the VM, that is different from the AD object... and that I have to put my AD users in this local group ;-(

And also I have to add user by user... it seems the local group add interface doesn't accept AD groups...

6) Now mstsc /v <IP_of_VM> works ok using one of those AD users

7) the user portal continues to not work: double click on vm doesn't produce anything...

 

After about ten minutes I get

A Request to the Server failed with the following Status Code: 500

 

It still remains the problem to preconfigure this, in particular if I'm configuring an automatic desktop pool..

 

 

One strange thing: in bottom center of IE I have the button "manage additional components"

If I click it, I see all the components added.

In particular I can see the spice and Java active components.

But I don't see any "rdp active component" that in theory should have been installed the first time....

I can't find it neither in the loaded components page, nor in the all components....

Any way to force reinstall of the rdp ActiveX component?  

RDP, unlike SPICE/VNC is a direct connection to the VM. If the VM has RDP closed (you need to open it, preferrably in the template before you sysprep it, so all the new VMs will have RDP enabled), or there is no access to port 3389 of the guest, RDP will not work.

 

I presume I have to preconfigure this way the win 7 vm candidate to become a template for a pool if I want then to allow rdp access, correct? Is this customization retained during sysprep?

 

Correct

 

 

And I have to put my users inside remote access list too

 

You can create a group, and add the group to the access list. Then modify the group in AD