kdump warning on startup

Latest response

Dear redhat Enterprise members

I have a Redhat EL6 basic server installation. 24Gb Ram,73 Gb disk for OS. swap = 26 Gb.Rest is for / but i am a very novice Redhat admin?

The following problem presented itself:
On startup kdump gives the following warning:
'Your running kernel is using more than 70% of the amount of space you reserved for kdump, you should consider increasing your crashkernel reservation'

I inserted 'crashkernel=128M rhgb quiet" in the grub.conf file in /etc as per the redhat manual for ES 6.

How serious is this warning? Can I disable the kdump and how? = chkconfig kdump off? So then I dont have any dump for a crash yes? What is standard/best practice?

Thanks to all!

Responses

This is explanation with recommended sizes: https://access.redhat.com/kb/docs/DOC-59801

 

If you do not need kdump functionality, just disable kdump. Obviously, if your server is experiencing kernel crashes or you expect hardware/kernel issues then it is always better to have kdump configured. RH support always asks for vmcore files produced by kdump in such cases.

I do not recommend disabling kdump.  We in Red Hat support will need a core to analyze most kernel panic issues, so if you disable it until its needed, then we won't capture a core the first time it happens.  Now you have to set up kdump, reboot, and then trigger the panic again (if its easily reproduceable, which often its not) just to get the same information. 

 

Aside from the small amount of memory and the time it takes to dump a core, there is no downside to having it installed and configured, and there is a large upside.

 

Even in situations where a kernel panic is not involved but rather the system is having performance issues or some other kernel-related problem, we'll ask you to force a panic and generate a dump.  Its usually convenient to already have it set up and not need to take downtime just to reboot and enter the parameters on the cmdline.

 

That said, the link provided in the previous comment should help you address this warning.

 

Let us know if you have any questions.

 

Regards,

John Ruemker, RHCA

Red Hat Software Maintenence Engineer

Online User Groups Moderator

Wonderfull!

 

It worked smoothly. I have 24 Gb Ram, so had to set the crashkernel=768M.

 

Most of the googled info still speak about RH 6 and lower. To always be brand new is not always a good thing then! HAHA!

 

Thanks a lot guys!

I have 96GB boxes that we use for virtualization hosts. Do I really need to reserve 3-4GB of RAM for the crashkernel?! That's enough to run another 1 or 2 guests (even without KSM). I'm okay with 768MB or so but 3 GB gets to be a lot of wasted memory.