CUPS Max clients reached... after upgrade from Centos 5.5 to Rhel 6.1

Latest response

I've upgraded a customer from Centos 5.5 i386 to RHEL 6.1 x86_64 and since then I'm frequently getting CUPS's "Max clients reached, holding new connections..."

 

The number of users is well below 100 ( normally 30-40 ) and the workload is the same.

 

Any suggestion?

 

best regards,

LF

 

Responses

Hi,

Does your /etc/cups/cupsd.conf have MaxClients set, or is relying on the default?

 

If the latter, maybe try setting MaxClients to 100, restart cupsd, and see if it goes away.  Perhaps the default has changed with RHEL 6 (intentionally or otherwise). 

 

[EDIT]: The code definitely still sets a default of 100:

 

  MaxClients               = 100;
  MaxClientsPerHost        = 0;
 

It would still be interesting to know if setting it manually helps, however, just to know if something else is going wrong with the setting of this variable. 

 

Also, you may want to turn up LogLevel to debug and see if any additional messages are spit out into the logs around that time.

 

[/EDIT]

 

In the meantime I'll see if any of our printing experts have other ideas.

 

Regards,

John Ruemker, RHCA

Red Hat Technical Account Manager

Online User Groups Moderator

I've added MaxClients 200 just to rise the bar over the default and see if it helps.

Thanks for the suggestion.

best regards,
LF